Page MenuHomePhabricator

Add the patroller group to the English Wikipedia
Closed, ResolvedPublic

Description

Add the patroller user group to the English Wikipedia.

  • patroller should have the patrol right.
  • patroller should be added and removed by sysop.
  • patrol should be removed from all other user groups (autoconfirmed, confirmed, and reviewer) except for sysop.

Relevant community discussions:

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
andymw updated the task description. (Show Details)Oct 25 2016, 12:14 AM
andymw added a subscriber: andymw.

As far as I know, bureaucrats don't have the patrol flag

@andymw, correct they do not on enwiki - checking with RfC closer - just as the RfC mentioned stewards this is not likely necessary - but if so it will need to be "added" to that group - not maintained.

According to the RfC the user right will be referred to locally in the future no longer as New Page Patroller, but as New Page Reviewer.

We will need data mining (Quarry?) to create a mass message list for the newsletter that has been prepared for all former and current patrollers.

Kudpung

Change 317752 had a related patch set uploaded (by Lixxx235):
enwiki: Create 'patroller' group with 'patrol' permission.

https://gerrit.wikimedia.org/r/317752

Change 317752 abandoned by Lixxx235:
enwiki: Create 'patroller' group with 'patrol' permission.

Reason:
Erm. I'm no good with formatting; I'll let someone else type in the characters I magically am not competent enough to type in.

https://gerrit.wikimedia.org/r/317752

DatGuy added a subscriber: DatGuy.Oct 25 2016, 7:16 AM

Regarding the gerrit patch, does patrol need to be added manually to 'crats or is it included since they have "sysop"?

Whatever needs to be done technically. It is intended that all ranks of sysop and above automatically have the new page reviewer right.

Change 317824 had a related patch set uploaded (by Cenarium):
Create patroller usergroup for enwiki

https://gerrit.wikimedia.org/r/317824

@Cenarium The patch does not give a short time frame in which non-admins can patrol articles, i.e. I think it makes sense to introduce the patroller group and allow some time for sysops to populate it while autoconfirmed still has the patrol flag. A second patch then removes the flag from autoconfirmed once patrollers are set.

@Cenarium The patch does not give a short time frame in which non-admins can patrol articles, i.e. I think it makes sense to introduce the patroller group and allow some time for sysops to populate it while autoconfirmed still has the patrol flag. A second patch then removes the flag from autoconfirmed once patrollers are set.

I agree. We're already having trouble figuring things out at WT:PERM, a two-step process seems most appropriate.

At the very least please wait on deploying this until we have a plan in place to promote our "grandfathered" users. Thanks!

Agree with @andymw. This should be a 2-step process.

Agreed as well :) I've updated the patch to only create the group.

That sounds best - this will move forward but having the overlap will avoid a break in service for potentially good reviews (it may be argued that breaking bad reviews is better but for a SHORT period it won't catch anything on fire).

OK, I've scheduled the deployment of Cenarium's patch for Thursday 23:00 UTC.

Do you have a patch for getting rid of the "patrol" permission from autoconfirmed users and pending changes reviewers as well?

Not yet, ask here when you want it done.

Dereckson added a comment.EditedOct 27 2016, 2:08 AM

Not yet, ask here when you want it done.

You can prepare this patch against the first patch you prepared following this procedure:

$ git review -d 317824
$ git checkout -b <some branch name>
# edit files
$ git commit
$ git review
[git-review will ask you to confirm you want to send TWO commits, the old one and the new one, answer yes]

You'll so have a change on Gerrit with the second patch, and the former patch as a dependency.

OK, I've scheduled the deployment of Cenarium's patch for Thursday 23:00 UTC.

Too soon. To wait the week-end will allow to be sure everyone agree on the last comments.

Furthermore, if we deploy this Monday or Tuesday, we have Tuesday to Thursday for the follow-up change or any other follow-up needed.

OK, I've scheduled the deployment of Cenarium's patch for Thursday 23:00 UTC.

Too soon. To wait the week-end will allow to be sure everyone agree on the last comments.
Furthermore, if we deploy this Monday or Tuesday, we have Tuesday to Thursday for the follow-up change or any other follow-up needed.

All of us at requests for permissions are ready. We have the list of grandfathered users, and everything is set up for folks to make requests. I say let's move forward with it. That will give us the whole weekend to advertise the new user group, process requests, and come next week there will be fewer people freaking out when they realize they can't patrol pages anymore.

You can prepare this patch against the first patch you prepared following this procedure:

Thanks, but I know how to push several commits at once. I just thought it was premature (and I don't have the time right now).

@Cenarium, @Kudpung: Deployment of the first patch has been delayed until Monday the 31st at 23:00 UTC just in case any one else wants to weigh in on the implementation details (per @Dereckson). Sorry for the delay.

Installing the grandfathered users will not take long. Perhaps one hour provided an admin or admins familiar with this project are available.

The second patch would be to erase the "'autoconfirmed' => [ 'patrol' => true ], // T14007" and "'reviewer' => [ 'patrol' => true ]," lines from InitialiseSettings.php.

Change 318515 had a related patch set uploaded (by Cenarium):
Remove patrol from autoconfirmed and reviewer for enwiki

https://gerrit.wikimedia.org/r/318515

Once the first patch comes out (on what I hear to be Halloween at 23:00 UTC), how long will it be until the next patch gets deployed?

Urbanecm added a subscriber: Urbanecm.EditedOct 29 2016, 5:45 AM

<s>The first deploy window is at Monday 13:00 UTC. But somebody (the patch author) must schedule it for this or another window. It's up to the patch author :). It could be the same window. In one window 8 patches can be handled. </s>

I scheduled it for the same window (I think they can be merged to one patch by the way), so both of them will be deployed at Monday 23:00 UTC. @Yoshi24517. Sorry @kaldari for adding it for you but I can't be available at 23:00 UTC and if you will assist during deploying the previous patch...

I scheduled it for the same window (I think they can be merged to one patch by the way), so both of them will be deployed at Monday 23:00 UTC. @Yoshi24517. Sorry @kaldari for adding it for you but I can't be available at 23:00 UTC and if you will assist during deploying the previous patch...

@Urbanecm They shouldn't be deployed in the same window or merged as they were split to allow enwiki admins to hand out the patroller group before removing access from autoconfirmed.

Okay. Will a week delay do? I am going to revert myself.

Reverted. I can schedule for November 7th. Do you agree?

A day or two should be enough, i.e. Thursday, November 03, if you can.

Urbanecm added a comment.EditedOct 29 2016, 12:35 PM

Okay, scheduled for November 03 13:00 UTC. Is it okay for you?

Yes, it's fine, thanks.

You're welcome.

Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.

Seems to be ready for deploy.

Assigned to the patch author.

Change 317824 merged by jenkins-bot:
Create patroller usergroup for enwiki

https://gerrit.wikimedia.org/r/317824

Mentioned in SAL (#wikimedia-operations) [2016-10-31T23:26:00Z] <thcipriani@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:317824|Create patroller usergroup for enwiki (T149019)]] (duration: 00m 46s)

kaldari closed this task as Resolved.Oct 31 2016, 11:43 PM
kaldari reopened this task as Open.Oct 31 2016, 11:50 PM

Actually, I guess I'll leave this open until we've done the follow-up changes to remove the right from the old groups.

The new group is present and appears to be working - thank you.

When will https://gerrit.wikimedia.org/r/318515, the patch that erases 2 lines from InitialiseSettings.php, be merged? The first change has already been merged.

When will https://gerrit.wikimedia.org/r/318515, the patch that erases 2 lines from InitialiseSettings.php, be merged? The first change has already been merged.

I'd say no earlier than Wednesday, maybe Thursday... we still have a lot of requests to go through and there's a steady stream of new ones coming in. What do you think @Xaosflux ?

Wed night or Thursday should be fine.

We've already scheduled this for Thursday, precisely November 03 13:00 UTC.

@Cenarium part two MAY need to be further delayed. While there are no issues with part-1, the community RfC for part 2 included getting a grandfathering process in for certain users - and it is being problematic.

See discussion: https://en.wikipedia.org/wiki/Wikipedia_talk:New_pages_patrol/Reviewers#Reported_issues_with_the_initial_NPR_grand-fathering_list

@Xaosflux Should I deschedule it or not? I'm prepared to take care about the deploy tomorrow :).

November 10 14:00 UTC. Will a week delay do?

That will likely be sufficient we should know in a couple of days.

Okay. If it won't do please tell me here. I'll reschedule it again.

@Dereckson Really working on? All relevant patches are scheduled so for us this is to deploy. Enwiki is (maybe?) works on this but we don't.

I've re-scheduled the last change for November 10 19:00 UTC (previous window was the same date but 14:00 UTC) due to my time unavailability in the sooner window. Sorry for the delay!

No worries, I put out one final call for community objections on enwiki.

@Cenarium @JJMC89

https://en.wikipedia.org/wiki/Wikipedia_talk:New_pages_patrol/Reviewers#Call_for_any_objections_to_allow_phase_2_of_the_patch

Shows that the enwiki community has not yet completed the migration of users for part 2 of this patch. Please push the deployment.

Again a week...

2016-11-16 14:00 UTC exactly :).

Dereckson reassigned this task from Cenarium to Urbanecm.Nov 15 2016, 6:41 PM
In T149019, @Urbanecm wrote:

2016-11-16 14:00 UTC exactly :).

What is the UTC time converted to PST (Pacific Standard Time)? I just wanna know because I mainly use that time zone and because I would like to know what time I will lose my patrolling privileges. Thanks!

In T149019, @Urbanecm wrote:

2016-11-16 14:00 UTC exactly :).

What is the UTC time converted to PST (Pacific Standard Time)? I just wanna know because I mainly use that time zone and because I would like to know what time I will lose my patrolling privileges. Thanks!

Currently the conversion is UTC -8. So that would be 0600 hrs pacific.

In T149019, @Urbanecm wrote:

2016-11-16 14:00 UTC exactly :).

What is the UTC time converted to PST (Pacific Standard Time)? I just wanna know because I mainly use that time zone and because I would like to know what time I will lose my patrolling privileges. Thanks!

Currently the conversion is UTC -8. So that would be 0600 hrs pacific.

Thank you @Cameron11598!

So by 6:00 AM PST tomorrow, "patrol" will disappear from the "autoconfirmed" and "reviewer" groups, leaving it only with "sysop" and the recently created "patroller". This also means that the "Mark others' edits as patrolled (patrol)" bullet will disappear from the "Autoconfirmed users" and "Pending changes reviewers" rows in Special:ListGroupRights. This change is going to make users get upset, crying "I cannot patrol pages anymore!" the first time they notice it, until they get used to the change.

We're not interested in what users will cry about. There have been two major RfC on this project and everyone has previously patrolled pages has been informed by newsletter. Anyone who can demonstrate suffiient competency to patrol new pages can apply for the right. in fact it's a great boon for the hat collectors, and note also that mhere were fewer than 30 or 40 truly active patrollers anyway and that's why the backlog is now at 14,000+ pages.

Change 318515 merged by jenkins-bot:
Remove patrol from autoconfirmed and reviewer for enwiki

https://gerrit.wikimedia.org/r/318515

Mentioned in SAL (#wikimedia-operations) [2016-11-16T14:18:19Z] <zfilipin@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:318515|Remove patrol from autoconfirmed and reviewer for enwiki (T149019)]] (duration: 00m 49s)

Urbanecm closed this task as Resolved.Nov 16 2016, 2:32 PM

Was done, autoconfirmed can no longer patrol new pages.