Page MenuHomePhabricator

When running runJobs.php, pages are created with the language tag of my default language
Closed, InvalidPublic

Description

Hi,

I remarked that when I use runJobs.php to force the queue jobs to run, some pages are created that I don't want to.
I use French for main language, so my pages names are set by default in this language.

When I use the script, pages like "Pagename/fr" are created, while I don't need them, because my page names defaults to French.
Even if I delete them, they come back to the next job queue running.

If possible, how can I control which pages are "rebuilt" using runJobs ?

I use MLEB 2016.08, and MediaWiki 1.27.1

EDIT: Steps to reproduce:

  • Have a page set in home language
  • Modify it
  • Mark the page for new translation
  • Validate the new translation parts
  • Run jobs.
  • Page/fr is created, although it shouldn't.

Event Timeline

Tuxxic created this task.Oct 25 2016, 3:20 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 25 2016, 3:20 PM
Tuxxic updated the task description. (Show Details)Oct 25 2016, 3:33 PM

This is intentional so that tag-less source text is available, for example for translatable templates which are transcluded there is no other way.

OK, it's fine then if it's not a bug. I will try to find ways around it.
Thanks for feedback !

Reedy closed this task as Invalid.Oct 26 2016, 5:00 PM