Page MenuHomePhabricator

As a person, I'd like to receive a notification from the Wikipedia app for whenever a certain article is updated
Closed, DuplicatePublic

Description

As a user, I'd like to receive an iOS notification from Wikipedia for whenever a certain article is updated. I'd like to know when information is changed, updated, and/or have deleted more information, which would also require implementing a diff-screen because there's no purpose in showing an article has updated if you don't know what exactly has been updated. This would similar to be a Special:Watchlist function, but I have no idea how much work this would require reimplementing in a new programming language (Swift), and other languages it could require (such as Objective C, since according to the GitHub repository located at https://github.com/wikimedia/wikipedia-ios, shows that that language is currently ~64% of the code.) I would also be willing to help with developing some mockups :)

Edit: Not only that, it'd generally require some other stuff such as:

  • A "Notifications" section in the Preferences
  • A placement for this feature in the UI while still being discoverable for the person using the app
  • Possibly changing the bottom navigation bar (which is already filled with 6 icons for 6 actions: TOC, change language, bookmark, share, change font-size, and mobile version of Ctrl+F/Cmd+F) Stuffing a 7th one would only make it more cluttery.
  • etc. etc.

Event Timeline

Restricted Application added a project: Wikipedia-iOS-App-Backlog. · View Herald TranscriptOct 28 2016, 2:23 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
SamanthaNguyen renamed this task from As a user, I'd like to receive an iOS notification from Wikipedia for whenever a certain article is updated to As a person, I'd like to receive an iOS notification from Wikipedia for whenever a certain article is updated.Oct 28 2016, 2:29 AM
SamanthaNguyen updated the task description. (Show Details)
SamanthaNguyen renamed this task from As a person, I'd like to receive an iOS notification from Wikipedia for whenever a certain article is updated to As a person, I'd like to receive a notification from the Wikipedia app for whenever a certain article is updated.Oct 28 2016, 4:52 AM
Dbrant closed this task as a duplicate of T76953: Add watchlist to app.Oct 28 2016, 1:04 PM