Page MenuHomePhabricator

Image container template is broken with the 1.28.0-wmf.23 ab831b0 update in Firefox at English Wikisource.
Closed, ResolvedPublic0 Estimate Story Points

Description

Using Firefox 50.0b11 beta, the template FIS is broken at the English Wikisource. When testing with Google Chrome Canary, the offset image displays correctly. The template was designed by [[User:George Orwell III]] to facilitate the display of offset images, particularly in the Popular Science Monthly project.

This is a random page of the result: https://en.wikisource.org/wiki/Page:Popular_Science_Monthly_Volume_55.djvu/360
This is a random image of the result: https://en.wikisource.org/wiki/File:Results_of_latest_1.28.0-wmf.23_ab831b0_update.jpg

Event Timeline

Ineuw created this task.Oct 29 2016, 7:40 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptOct 29 2016, 7:40 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
AuFCL added a subscriber: AuFCL.Oct 29 2016, 9:17 PM

Some background if I may:

This effect is an artefact of the directive within enWS' system common.css:

@import url('/w/index.php?title=MediaWiki:Dynimg.css&action=raw&ctype=text/css') screen;

being mis-interpreted as

@import url(//sr.wikisource.org/w/index.php?title=MediaWiki:Dynimg.css&action=raw&ctype=text/css) screen;

as evidenced by Firefox (49.0) Web Developer/Style Editor tool (which also usefully issues the warning: "Style sheet could not be loaded. https://sr.wikisource.org/w/index.php?title=MediaWiki:Dynimg.css&action=raw&ctype=text/css" in white on red background. Bit of a hint?

Could this be related to the javascript console logging to the effect various Gadget stylesheets are being loaded twice due to T42284 not (yet) having been addressed on enWS? A typical message being:

Gadget "Site" styles loaded twice. Migrate to type=general. See <https://phabricator.wikimedia.org/T42284>.

loading in edit mode the web developer generates the following in Firefox:

Gadget "CollapsibleNav" styles loaded twice. Migrate to type=general. See https://phabricator.wikimedia.org/T42284. index.php:102:45
This page is using the deprecated ResourceLoader module "jquery.ui.widget". load.php:31:289
This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead. load.php:1:80

Ineuw added a comment.Oct 30 2016, 5:15 AM

loading in edit mode, the console of web developer generates the following code in Chrome

index.php?title=Page:Popular_Science_Monthly_Volume_55.djvu/360&action=edit:102 Gadget "CollapsibleNav" styles loaded twice. Migrate to type=general. See https://phabricator.wikimedia.org/T42284.
(anonymous) @ index.php?title=Page:Popular_Science_Monthly_Volume_55.djvu/360&action=edit:102
push @ load.php?debug=false&lang=en&modules=startup&only=scripts&skin=vector:63
(anonymous) @ index.php?title=Page:Popular_Science_Monthly_Volume_55.djvu/360&action=edit:102
VM363:8 This page is using the deprecated ResourceLoader module "jquery.ui.widget".
(anonymous) @ VM363:8
(anonymous) @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:161
fire @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:45
add @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:45
always @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:46
runScript @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:161
checkCssHandles @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:162
execute @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:163
implement @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:169
(anonymous) @ VM363:8
(anonymous) @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:4
globalEval @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:4
(anonymous) @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:166
(anonymous) @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:177
VM363:3 This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead.
mw.loader.implement.css @ VM363:3
(anonymous) @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:161
fire @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:45
add @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:45
always @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:46
runScript @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:161
checkCssHandles @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:162
(anonymous) @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:162
fire @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:45
fireWith @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:46
fire @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:46
fireCallbacks @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:156
addEmbeddedCSS @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:157
(anonymous) @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=0803kc5:156

I could reproduce the problem only once (being logged in, Firefox 49). After going to https://en.wikisource.org/wiki/Page:Popular_Science_Monthly_Volume_55.djvu/360?debug=true (and bypassing the browser cache) I cannot reproduce it anymore at all. :-/

Ineuw added a comment.Oct 30 2016, 7:33 PM

Just looked at the page and it is OK. But, I disabled my gadgets yesterday. Please keep the ticket open for 24 hours, and let me see if it still be OK as I continue working, with and without the gadgets.

Ineuw added a comment.Oct 30 2016, 7:45 PM

Also need some clarification on the bewildering variety of cache clearing options, which does what?:

  1. There is an option middle of the buttons, on the top right of Index pages: https://en.wikisource.org/wiki/Index:Popular_Science_Monthly_Volume_55.djvu. I assume this purges the Commons djvu repository, but I am not sure.
  2. Gadget: A "*" tab or a "Purge" option within the actions-tab, which purges the page's cache when followed. This adds a purge and a Hard purge control, whatever that means.
  3. Gadget: Clock and Purge. A clock in the personal toolbar that shows the current time in UTC and be clicked to purge the page.
  4. Clear one's browser cache.

There are more but I think you get my meaning.

AuFCL added a comment.Oct 31 2016, 2:36 AM

@Ineuw: For my money this glitch is entirely related to browser-end caching and not at all related to Gadget or Purge alternatives. (I have no idea why one of my machines occasionally requests the Serbian version of Dynimg.css; a different machine never once seems to.) May I recommend a more conservative encoding within https://en.wikisource.org/wiki/MediaWiki:Common.css, re-expressing:

/* end baseline See  [[MediaWiki:Gadget-Site.css]]  for remaining CSS loaded */
@import url('/w/index.php?title=MediaWiki:Dynimg.css&action=raw&ctype=text/css') screen;
/*	Stylesheets being tested	*/
@import url('/w/index.php?title=MediaWiki:Coltest.css&action=raw&ctype=text/css') screen;

instead as:

/* end baseline See  [[MediaWiki:Gadget-Site.css]]  for remaining CSS loaded */
@import url('//en.wikisource.org/w/index.php?title=MediaWiki:Dynimg.css&action=raw&ctype=text/css') screen;
/*	Stylesheets being tested	*/
@import url('//en.wikisource.org/w/index.php?title=MediaWiki:Coltest.css&action=raw&ctype=text/css') screen;

i.e. explicitly specifying the server name (and thus language-variant)?

(I remain open to suggestions/recommendations/thoughts as to why the occasional wrong language request is polluting my browser cache but cannot state if that is the identical issue others are seeing.)

Ineuw closed this task as Resolved.Oct 31 2016, 3:30 AM
Ineuw claimed this task.

Please close this ticket. With purging of the caches the images are displayed properly.

Jdforrester-WMF set the point value for this task to 0.
AuFCL removed a subscriber: AuFCL.Nov 21 2016, 7:41 PM