Unnecessary words "Creating Category" appear when editing a category page
Closed, ResolvedPublic

Description

When creating or editing a category page that has categories on it, when doing a preview, there's a section that normally reads Pages in category "CATEGORYPAGE" that now reads Pages in category "Creating Category:CATEGORYPAGE" or Pages in category "Editing Category:CATEGORYPAGE".

Steps to reproduce:

  1. Go to any category page that has at least one page listed under Pages in category "CATEGORYPAGE"
  2. Edit the category page, and hit preview.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 30 2016, 1:52 AM

This can be seen on Wikipedia, while I can't see it in a random 1.27 wiki, so I call it a regression

Seems to be caused by rMW8ccde8984913896d59a3c2b529768cfe74100afd (T43720#2531611) and there seems to be a fix in gerrit:305991 but not merged... Change should be merged before 1.28 or the merged commit reverted.

Amire80 renamed this task from Text glitch in "Pages in category" when editing a category page to Unnecessary words "Creating Category" appear when editing a category page.Nov 6 2016, 1:00 PM
Krenair added a subscriber: Krenair.Nov 8 2016, 2:38 PM

Change 305432 had a related patch set uploaded (by Liuxinyu970226):
Revert "Use display name in category page subheadings if provided"

https://gerrit.wikimedia.org/r/305432

Change 305432 merged by jenkins-bot:
Revert "Use display name in category page subheadings if provided"

https://gerrit.wikimedia.org/r/305432

Change 320544 had a related patch set uploaded (by Bartosz Dziewoński):
Revert "Use display name in category page subheadings if provided"

https://gerrit.wikimedia.org/r/320544

Change 320544 merged by jenkins-bot:
Revert "Use display name in category page subheadings if provided"

https://gerrit.wikimedia.org/r/320544

matmarex closed this task as Resolved.Nov 9 2016, 12:35 AM
matmarex removed a project: Patch-For-Review.
matmarex claimed this task.

Reverted and backported to MW 1.28. I did not backport to wmf branches, it was already broken for a while, so it can wait another week I guess…