Create Wikisource Eastern Punjabi
Closed, ResolvedPublic

Description

The language committee has approved the creation of Wikisource Eastern Punjabi.

https://meta.wikimedia.org/wiki/Requests_for_new_languages/Wikisource_Eastern_Punjabi

Language code: pa
Site URL: pa.wikisource.org
Project name: ਵਿਕੀਸਰੋਤ
Project namespace: ਵਿਕੀਸਰੋਤ
Project talk namespace: ਵਿਕੀਸਰੋਤ ਗੱਲ-ਬਾਤ
Project logo: https://commons.wikimedia.org/wiki/File:Wikisource-logo-pa-v6.svg
Timezone: Asia/Kolkata

[Local file uploads: tbd]

Thank you.

There are a very large number of changes, so older changes are hidden. Show Older Changes

It doesn't look like this has language comittee approval

Indeed not.

MF-Warburg closed this task as Declined.Nov 11 2016, 4:05 AM
Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptNov 11 2016, 4:05 AM
Dcljr added a subscriber: Dcljr.Nov 11 2016, 4:28 AM

Note to the creator of this task: Submitting a Phabricator task is the final step in the process of creating a new Wikimedia wiki. Meta requests need to be completed before the task is created.

satdeep_gill reopened this task as Open.Feb 27 2017, 2:42 PM

Creation of Punjabi Wikisource has been approved by the Language Committee.

https://meta.wikimedia.org/wiki/Requests_for_new_languages

Langcom discussion for approval is located at https://lists.wikimedia.org/pipermail/langcom/2017-February/thread.html#1049

Translation was an issue noted in this discussion, but there is an ongoing effort, and core messages are translated.

@satdeep_gill as it's a wikisource and you're using OCR, the real priority would be to translate the last messages for Proofreadpage: https://translatewiki.net/w/i.php?title=Special:Translate&language=pa&group=ext-proofreadpage&filter=%21translated

Current configuration requires local upload, but no EDP has been drafted on Incubator, so I'm not inclined to enable them.

Finally, it should be noted, @satdeep_gill is now a langcom member, and as such, has now authority to update this task.

@Derekson What should we do about the EDP ?

Besides that, I have translated the last messages for Proofreadpage. Thanks for reminding me about this.

Dereckson added a comment.EditedFeb 27 2017, 3:56 PM

Thanks for the translation.

An EDP is a policy explaining what kind of files are allowed to upload, and compatible with Wikimedia licensing policy.

Without a need for non free files, you should prefer Commons upload.

I think you should decide whether to have non-Commons images or not. If no, local upload isn't necessary. If yes, people will ask what you want to upload locally - we've had issues with shoddy copyright practices in smaller projects that allow uploads.

-jkb- added a comment.Feb 27 2017, 5:40 PM

Just a hint: to avoid that wikisource documents could be changed on Commons I practiced and practice the use of a special template like
https://commons.wikimedia.org/wiki/Template:CsSource
which is placed in such documents. It seems to work.

We need local upload for books that are in public domain in India. Other language wikisources are using this as well. Should we translate the Wikimedia Licensing Policy into Punjabi ?

Ankry added a subscriber: Ankry.Feb 27 2017, 9:10 PM

Books that are PD in home country and PD in US can go to Commons.

Books that are not free in US should not be uploaded to any Wikimedia project

We need local upload for books that are in public domain in India.

Do you mean books that are PD in US and not PD in India? Are there such books in Punjabi?

MF-Warburg renamed this task from Make Punjabi Wikisource (pa.wikisource.org) a live project to Create Wikisource Eastern Punjabi.Feb 27 2017, 10:02 PM
MF-Warburg updated the task description. (Show Details)
MF-Warburg updated the task description. (Show Details)Feb 27 2017, 10:18 PM

IIRC, Wikisources have the "Page", "Page talk", "Index", "Index talk" namespaces and the translation for those is usually given in the bug report to create the wiki, as they are not translatable on TWN. Correct?

@Ankry, Please check this: https://en.wikipedia.org/wiki/Template:PD-India

@MF-Warburg: Do I need to give the translations for Page and Index here ?

The resolution specifies "Such EDPs must be minimal.".

To publish books in public domain in India but not yet in US doesn't qualify as minimal: it's not an illustration to increase the understanding, like a logo, a building or a stamp, but the main content. As such, I don't think this exception would be compatible with the resolution.

@Dereckson As per knowledge, PD-India is being used on other Wikisource projects. I would have verify that. But for now, let us disable local uploads.

@Lydia_Pintscher I presume that we need to alert Wikidata to this addition. You or someone else?

Adding @aude and @hoo to have a look.

How much is the average time taken to create a new wiki ?

Here are the translations:

Page: ਸਫ਼ਾ
Page talk: ਸਫ਼ਾ ਗੱਲਬਾਤ
Index: ਇੰਡੈਕਸ
Index talk: ਇੰਡੈਕਸ ਗੱਲਬਾਤ

Also please enable local uploads because there will be works which are in Public Domain in US but not in India. Like this:
https://en.wikisource.org/wiki/File:Shivaji_and_His_Times.djvu

Dereckson added a comment.EditedMar 9 2017, 12:22 PM

Thanks for the update.

Now, we've all the required information I'll start to prepare the required changes, the first steps will be done next week.

Dereckson triaged this task as Normal priority.Mar 9 2017, 12:25 PM

@Dereckson The week has almost passed. Have the first steps been performed ?

@Dereckson The week has almost passed. Have the first steps been performed ?

Procedure will be tracked in real time on this ticket, there are a dozen of steps to perform, requiring the involvment of different people, so please be patient.

Change 343552 had a related patch set uploaded (by Dereckson):
[operations/puppet] Add pa.wikisource new wiki on RESTBase

https://gerrit.wikimedia.org/r/343552

I am unable to see any progress realtime.

@satdeep_gill: That's because there has been no progress. If there was progress, it could be seen in this ticket.
Currently, the patch in https://gerrit.wikimedia.org/r/#/c/343552/ needs a manual rebase.

Who should i approach to make this happen ?

-jkb- removed a subscriber: -jkb-.Apr 12 2017, 6:01 PM

@satdeep_gill You're welcome to continue to contribute to multilanguage wikisource pending the wiki creation, any content will be imported, including new content

@Dereckson is there any tentative date by which the wiki will be created ? Like the end of this month ?

Dereckson added a comment.EditedApr 13 2017, 8:42 AM

Scheduling

2017-04-13 21:00–23:00 UTC (calendar)

Why this request wasn't processed more swiftly?

So, in the past few weeks, we've received wave of several wikis to create from Langcom. The idea was to consolidate them and create them as a set, but a lot of issues occur: translation not done, logo missing, sockpuppets, namespace and language name translations disagreements.

It now appears it's not reasonable to expect swift resolutions for all these issues, and so I'm going to create these wikis one by one instead, when the requests will be ready.

Dereckson added a comment.EditedApr 13 2017, 6:11 PM

I'm not satisfied with local upload rationale, so I won't enable it today. We'll be able to enable it later when it will be clarified.

Okay. So, you will be creating this wiki today ?

Yes, in a few minutes.

Change 348148 had a related patch set uploaded (by Dereckson):
[operations/mediawiki-config@master] Initial configuration for pa.wikisource

https://gerrit.wikimedia.org/r/348148

Change 348148 merged by jenkins-bot:
[operations/mediawiki-config@master] Initial configuration for pa.wikisource

https://gerrit.wikimedia.org/r/348148

Mentioned in SAL (#wikimedia-operations) [2017-04-13T22:12:02Z] <dereckson@tin> Synchronized dblists: pa.wikisource creation (T149522) (duration: 00m 41s)

Mentioned in SAL (#wikimedia-operations) [2017-04-13T22:14:23Z] <dereckson@tin> Synchronized static/images/project-logos/: Logos for pa.wikisource (T149522) (duration: 00m 41s)

Mentioned in SAL (#wikimedia-operations) [2017-04-13T22:15:48Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Initial configuration for pa.wikisource (T149522) (duration: 00m 41s)

Change 348170 had a related patch set uploaded (by Dereckson):
[operations/mediawiki-config@master] Interwiki map update

https://gerrit.wikimedia.org/r/348170

Change 348170 merged by jenkins-bot:
[operations/mediawiki-config@master] Interwiki map update

https://gerrit.wikimedia.org/r/348170

Meno25 added a subscriber: Meno25.Apr 14 2017, 6:58 AM

I'm not satisfied with local upload rationale, so I won't enable it today. We'll be able to enable it later when it will be clarified.

I believe that they are wanting to replicate English Wikisource in just having PD-1923 as their exclusion criteria, so where Commons rejects uploads, that they can then host them. Maybe they can have an abuse filter that restricts uploads to a user group if you have concerns about potential abuse.

@Billinghurst Would you know who generally do the imports for Wikisource
projects?

@Dereckson As per knowledge, PD-India is being used on other Wikisource projects. I would have verify that. But for now, let us disable local uploads.

For all Indic Wikisource, only local admin can upload local upload.

@Dereckson As per knowledge, PD-India is being used on other Wikisource projects. I would have verify that. But for now, let us disable local uploads.

For all Indic Wikisource, only local admin can upload local upload.

@Dereckson ^^^ that sounds like the ideal starting point, especially if a file is being deleted at Commons and the community allows the work.

Actually, the ideal starting point would be a review of all Wikisouce EDP.

< 1923 looks fine on en.wikisource because I assume en. projects elect to respect US law and only this one.

But to export this to countries without the 1923 threshold won't work if the uploaded media isn't also in public domain in source country.

But if a file is in public domain AND in US AND in source country, you can upload it to Commons.

Mentioned in SAL (#wikimedia-operations) [2017-04-19T07:26:52Z] <hoo> Updated the sites and site_identifiers tables on all Wikidata clients for T149522.

hoo added a comment.Apr 19 2017, 8:23 AM

Wikidata specific steps taken and confirmed: https://www.wikidata.org/w/index.php?diff=476527413.

Change 349967 had a related patch set uploaded (by Dereckson):
[mediawiki/services/restbase/deploy@master] Add pa.wikisource.org

https://gerrit.wikimedia.org/r/349967

Change 343552 abandoned by Dereckson:
Add pa.wikisource new wiki on RESTBase

Reason:
Superseded by https://gerrit.wikimedia.org/r/349967

https://gerrit.wikimedia.org/r/343552

Change 349967 merged by Mobrovac:
[mediawiki/services/restbase/deploy@master] Add pa.wikisource.org

https://gerrit.wikimedia.org/r/349967

Next step is to add it to WikiStats

Dzahn added a subscriber: Dzahn.

all done here now? (sorry for the delay with that minimal subtask)

Dereckson closed this task as Resolved.May 20 2017, 5:39 PM
Dereckson claimed this task.

Yes, all the tasks have been done.

Meno25 removed a subscriber: Meno25.Aug 26 2017, 10:29 AM
satdeep_gill reopened this task as Open.Sun, Dec 10, 6:59 AM

Kindly enable local uploads for sysops on pa.wikisource.org.

As noted T149522#3057977 and my post beneath it, it is not clear if such is warranted. (Incidentally, I am not sure if "Books that are not free in US should not be uploaded to any Wikimedia project" is correct - certainly I do have the impression that dewiki uses the copyright policies of Germany, Austria and Switzerland instead. I never understood why)

Aklapper closed this task as Resolved.Sun, Dec 10, 12:03 PM

Kindly enable local uploads for sysops on pa.wikisource.org.

Please file new / separate tasks for new / separate requests. See https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes . Thanks.