Page MenuHomePhabricator

require in extension regestration does not work properly
Closed, ResolvedPublic

Description

Steps to reproduce

But it seems that doing

	"require": {
		"MediaWiki": ">= 1.28.0"
	},

doesn't correctly work since manifest_version seems to be checked first. But this should be the first thing check to show user friendly error.

Details

Related Gerrit Patches:

Event Timeline

Paladox created this task.Nov 1 2016, 10:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 1 2016, 10:59 PM
Reedy updated the task description. (Show Details)Nov 1 2016, 11:01 PM

Change 319244 had a related patch set uploaded (by Reedy):
Check MW version requires before manifest_version

https://gerrit.wikimedia.org/r/319244

Florian closed this task as Resolved.Nov 2 2016, 10:14 AM
Florian assigned this task to Reedy.
Florian triaged this task as Medium priority.
Florian removed a project: Patch-For-Review.

Change 319244 merged by jenkins-bot:
Check MW version requires before manifest_version

https://gerrit.wikimedia.org/r/319244