Page MenuHomePhabricator

Flow fatal: Default format of 'topic-title-html' or 'topic-title-wikitext' can only be used to format topic titles.
Closed, ResolvedPublic

Description

On https://mediawiki.org/w/index.php?title=Topic:R017r5i1sq5edfia&action=edit-title&topic_postId=r017r5i1sq5edfia&topic_format=topic-title-wikitext :

2016-11-02 18:53:06 [WBo2EgpAAD8AAZeMPasAAAAM] mw1268 mediawikiwiki 1.29.0-wmf.1 exception ERROR: [WBo2EgpAAD8AAZeMPasAAAAM] /w/index.php?title=Topic:R017r5i1sq5edfia&action=edit-title&topic_postId=r017r5i1sq5edfia&topic_format=topic-title-wikitext   Flow\Exception\FlowException from line 1159 of /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/Formatter/RevisionFormatter.php: Default format of 'topic-title-html' or 'topic-title-wikitext' can only be used to format topic titles. {"exception_id":"WBo2EgpAAD8AAZeMPasAAAAM"} 
[Exception Flow\Exception\FlowException] (/srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/Formatter/RevisionFormatter.php:1159) Default format of 'topic-title-html' or 'topic-title-wikitext' can only be used to format topic titles.
  #0 /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/Formatter/RevisionFormatter.php(1102): Flow\Formatter\RevisionFormatter->decideNonTopicTitleContentFormat(Flow\Model\PostSummary, NULL, string)
  #1 /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/Formatter/RevisionFormatter.php(266): Flow\Formatter\RevisionFormatter->decideContentFormat(Flow\Model\PostSummary)
  #2 /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/Formatter/RevisionFormatter.php(284): Flow\Formatter\RevisionFormatter->formatApi(Flow\Formatter\FormatterRow, Flow\View, string)
  #3 /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/Block/Topic.php(679): Flow\Formatter\RevisionFormatter->formatApi(Flow\Formatter\TopicRow, Flow\View)
  #4 /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/Block/Topic.php(559): Flow\Block\TopicBlock->renderPostApi(array)
  #5 /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/View.php(193): Flow\Block\TopicBlock->renderApi(array)
  #6 /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/View.php(68): Flow\View->buildApiResponse(Flow\WorkflowLoader, array, string, array)
  #7 /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/Actions/Action.php(112): Flow\View->show(Flow\WorkflowLoader, string)
  #8 /srv/mediawiki/php-1.29.0-wmf.1/extensions/Flow/includes/Actions/Action.php(50): Flow\Actions\FlowAction->showForAction(string)
  #9 /srv/mediawiki/php-1.29.0-wmf.1/includes/MediaWiki.php(505): Flow\Actions\FlowAction->show()
  #10 /srv/mediawiki/php-1.29.0-wmf.1/includes/MediaWiki.php(289): MediaWiki->performAction(Article, Title)
  #11 /srv/mediawiki/php-1.29.0-wmf.1/includes/MediaWiki.php(861): MediaWiki->performRequest()
  #12 /srv/mediawiki/php-1.29.0-wmf.1/includes/MediaWiki.php(522): MediaWiki->main()
  #13 /srv/mediawiki/php-1.29.0-wmf.1/index.php(43): MediaWiki->run()
  #14 /srv/mediawiki/w/index.php(3): include(string)
  #15 {main}

mysql:research@x1-analytics-slave [flowdb]> SELECT HEX(workflow_id), workflow_wiki, workflow_title_text, rev_change_type, rev_flags FROM flow_workflow JOIN flow_revision ON rev_type_id = workflow_id WHERE workflow_id IN (UNHEX( '04f00726ca8cffa60531c2' ), UNHEX( '0560a2d165f49806e6a5c2' ) ) AND rev_change_type = 'new-post';
+------------------------+---------------+---------------------+-----------------+------------------------------------------+
| HEX(workflow_id)       | workflow_wiki | workflow_title_text | rev_change_type | rev_flags                                |
+------------------------+---------------+---------------------+-----------------+------------------------------------------+
| 04F00726CA8CFFA60531C2 | mediawikiwiki | How_to_contribute   | new-post        | utf-8,gzip,wikitext,external             |
| 0560A2D165F49806E6A5C2 | mediawikiwiki | Sandbox/Flow_test   | new-post        | utf-8,gzip,topic-title-wikitext,external |
+------------------------+---------------+---------------------+-----------------+------------------------------------------+
2 rows in set (0.63 sec)

Event Timeline

Matanya created this task.Nov 2 2016, 6:25 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptNov 2 2016, 6:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Matanya renamed this task from [Bug] flow fatal in 1.29-wmf01 to [Bug] flow fatal in 1.29-wmf.1.Nov 2 2016, 6:26 PM
Matanya updated the task description. (Show Details)
Matanya updated the task description. (Show Details)
Catrope added a subscriber: Catrope.Nov 2 2016, 6:38 PM

What's the actual error message / exception? The task description only contains a backtrace.

Catrope renamed this task from [Bug] flow fatal in 1.29-wmf.1 to Flow fatal: Default format of 'topic-title-html' or 'topic-title-wikitext' can only be used to format topic titles..Nov 2 2016, 6:58 PM
Catrope updated the task description. (Show Details)

From IRC:

[Thursday, November 03, 2016] [11:26:17 AM] <stephanebisson> [2016-11-02 15:16:31] RoanKattouw: re edit-title: Not trivial to reproduce. Maybe data-specific. This specific topic looks old (maybe a LQT import) and doesn't even show up on its board (https://www.mediawiki.org/wiki/Talk:How_to_contribute).

E.g. https://www.mediawiki.org/w/index.php?title=Topic:Temn8cbfr1062w8y&action=edit-title&topic_postId=temn8cbfr1062w8y&topic_format=topic-title-wikitext works fine.

The trace indicates it may only be topics with summaries, haven't finished tracking it down yet.

If this is determined to be a UBN, feel free to assign it to someone else, since I am on vacation tomorrow.

Change 321835 had a related patch set uploaded (by Mattflaschen):
Fix editing the titles of topics with summaries

https://gerrit.wikimedia.org/r/321835

@Mattflaschen-WMF Is the link that's causing the error available somewhere in the UI or do you have to construct it manually? I'd like to test the patch but I can't reproduce the issue locally.

@SBisson Yes, the link is there. Open 'Edit title' in a new tab, for a topic with a summary.

@SBisson Yes, the link is there. Open 'Edit title' in a new tab, for a topic with a summary.

Thanks!

Change 321835 merged by jenkins-bot:
Fix editing the titles of topics with summaries

https://gerrit.wikimedia.org/r/321835

I fixed it by changing how the URL is generated. To test, go to https://www.mediawiki.org/w/index.php?title=Topic:R017r5i1sq5edfia , then click "Edit title".

That old URL is still broken, but it's not linked from the user interface, so it shouldn't affect users.

jmatazzoni closed this task as Resolved.Dec 14 2016, 7:39 PM
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:10 PM