Page MenuHomePhabricator

[Spike 1hr] Double-check through old hovercards EL related bugs
Closed, ResolvedPublic

Description

Acceptance Criteria

  • Double check the following:

Multiple bugs are happening when following the following steps. I didn't notice these bugs while doing a manual check as part of T145665#2675674, so I suppose the bugs were introduced recently, probably as part of a large refactoring we did in T147846.

Browser: Chrome 53.0.2785.143 (64-bit)
OS: Mac OS 10.11.6 (15G1004)

  1. Visit http://reading-web-staging.wmflabs.org, login and opt-in for the Hovercards beta feature.
  2. Go to http://reading-web-staging.wmflabs.org/wiki/Book and open the browser console.
  3. Hover or the first link (β€œink”) and quickly command click it (before a hover card shows up). Two bugs are happening here:
    • You’ll notice the error β€œVM1937:126 Uncaught TypeError: Cannot read property 'off' of null” in the console.
    • Both β€œopened in new tab” and β€œdwelled but abandoned” events are logged.
  4. Another bug happens here: wait about 10 seconds and hover over the same link again and command click it after you see a hover card. You’ll notice that the 10 second wait is also included in the logged event even though you waited 10 seconds before hovering over the link.
  5. Create bugs for any encountered issues

Details

Related Gerrit Patches:
operations/mediawiki-config : masterRe-enable Page Previews instrumentation

Related Objects

Event Timeline

bmansurov created this task.Nov 3 2016, 8:41 PM
Restricted Application added a subscriber: Aklapper. Β· View Herald TranscriptNov 3 2016, 8:41 PM
phuedx added a subscriber: phuedx.Nov 3 2016, 9:32 PM
  • You’ll notice the error β€œVM1937:126 Uncaught TypeError: Cannot read property 'off' of null” in the console.

Should we merge this with T148945: Cannot read property 'off' of null?

Also, my gut says that bugs 3.2 and 4 are caused by 3.1.

Good call, @phuedx. Feel free.

ovasileva changed the task status from Open to Stalled.Nov 9 2016, 5:55 PM
ovasileva added subscribers: β€’ Tbayer, ovasileva.

@Tbayer - fyi

In T149947, @phuedx wrote:
  • Both β€œopened in new tab” and β€œdwelled but abandoned” events are logged.

That's reminiscent of T140485, right?

ovasileva triaged this task as Medium priority.Nov 17 2016, 9:16 PM

@bmansurov - could you test through the new code and resolve if fixed?

@ovasileva Should we instead pull this into the sprint and estimate and pass it through our process?

ovasileva renamed this task from Hovercards EL related bugs to Double-check through old hovercards EL related bugs.Mar 1 2017, 6:45 PM
phuedx added a comment.EditedMar 1 2017, 6:47 PM

This task'll be picked up by an engineer. We're expected to reproduce bugs #3 and #4 and fix 'em if they're still present.

ovasileva renamed this task from Double-check through old hovercards EL related bugs to [Spike 1hr] Double-check through old hovercards EL related bugs.Mar 1 2017, 6:52 PM
ovasileva updated the task description. (Show Details)
β€’ Tbayer added a comment.EditedMar 2 2017, 7:45 AM

Edit: nevermind, it looks like T157700 is a better place to discuss this, I have followed up there instead.

Actually it seems that the primary bug is that the new version isn't sending any events at all currently (drop to almost 0 since February 23)... Shall we open a new task for this? (Also, the information at https://meta.wikimedia.org/wiki/Schema_talk:Popups#Sampling should be updated.)

Change 340706 had a related patch set uploaded (by Phuedx):
[operations/mediawiki-config] Re-enable Page Previews instrumentation

https://gerrit.wikimedia.org/r/340706

Change 340706 merged by Phuedx:
[operations/mediawiki-config] Re-enable Page Previews instrumentation

https://gerrit.wikimedia.org/r/340706

pmiazga added a comment.EditedMar 2 2017, 10:51 PM

Tested:

3.1 - does not happen any more
3.2 - opened event is sent only when "open in new tab" is performed on a link (not on a popup)
4 - I don't see any "wait" property in the event, only totalInteractionTime that always starts from the moment I hovered a link. There is no information how much time has passed from page load. But I think there might be a possibility to extract this information as on page load we sent pageLoaded event with page token, and then every dismissed/opened/dwelledButAbandoned event has the same page token. @phuedx could you confirm?

I left all my findings/funky events behavior in T159490

phuedx added a comment.EditedMar 3 2017, 5:43 AM

I don't see any "wait" property in the event, only totalInteractionTime that always starts from the moment I hovered a link. There is no information how much time has passed from page load. But I think there might be a possibility to extract this information as on page load we sent pageLoaded event with page token, and then every dismissed/opened/dwelledButAbandoned event has the same page token. @phuedx could you confirm?

The property that you need to test is totalInteractionTime.

phuedx updated the task description. (Show Details)Mar 3 2017, 5:44 AM
pmiazga added a comment.EditedMar 3 2017, 1:53 PM

Point 4. Total interaction time for events dismissed and dwelledButAbandoned is calculated correctly, but for totalInteractionTime for opened event looks pretty random and I cannot find any correlation between my actions and logged value.

Scenario a) - go to page, hover a link, open a link in new tab before popup is visible, totalInteractionTime = 37
Scenario b) - go to page, wait 15 seconds, hover a link, wait for popup to be visible, open link in new tab, totalInteractiontime = 53
Scenario c) - go to page, hover a link, read popup for 15 seconds, open link in new tab, totalInteractionTime = 34
Scenario d) - go to page, hover a link, read popup, move mouse over popup, move mouse back over a link and open in new tab, totalInteractionTime = 46

Value in totalInteractionTime doesn't have sense. Tested on Firefox 51 & Chrome 55. I created a separate phab task to fix it: T159539

phuedx reassigned this task from pmiazga to ovasileva.Mar 6 2017, 12:49 PM
phuedx added a subscriber: pmiazga.
ovasileva closed this task as Resolved.Mar 6 2017, 5:11 PM

bugs opened for all outstanding issues