Page MenuHomePhabricator

Don't autopatrol autoreviewed users in protection-based configs
Closed, ResolvedPublic

Description

On one hand, when using RC patrol, it implies that autoreviewed users are autopatrolled on pages with pending changes, but not on others. This prevents regular patrol of those users (who often are merely autoconfirmed) on pending changes protected pages. On those wikis, the autopatrolled permission requires a much higher level of trust.

On the other hand, when not using RC patrol, but only NP patrol, it creates automatic log entries that appear weird to end users, since they're not for new pages. They're completely unnecessary.

Details

Related Gerrit Patches:

Event Timeline

Cenarium created this task.Nov 5 2016, 2:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 5 2016, 2:06 PM
Cenarium updated the task description. (Show Details)Nov 5 2016, 2:16 PM

Change 315109 had a related patch set uploaded (by Cenarium):
Don't autopatrol autoreviewed users in protection-based configs

https://gerrit.wikimedia.org/r/315109

Change 315109 merged by jenkins-bot:
Don't autopatrol autoreviewed users in protection-based configs

https://gerrit.wikimedia.org/r/315109

GeoffreyT2000 closed this task as Resolved.Jan 15 2017, 9:35 PM