Page MenuHomePhabricator

"copy all fields" button disappears from Commons upload after problem with upload check
Closed, ResolvedPublic

Description

I tried to upload a set of files through Commons upload wizard
https://commons.wikimedia.org/wiki/Special:UploadWizard

They were part of a set and had common information. Typically, after the first file in a list, there is a tool to copy all the information from the first item in a set to everything else.

Upon pressing "upload", the uploader checks for all sorts of errors, then halts the finalization if something needs to be corrected first. In my case I linked to a blacklisted website. That's fine - I can remove the link - but the problem was that this particular error also caused the "copy everything" tool to inappropriately disappear. I would have liked to retain it, so that I could correct the link in the first image and copy those changes to the entire set.

The problem is that without that tool I had to manually change each description.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 11 2016, 11:33 AM
Restricted Application added a project: Multimedia. · View Herald TranscriptNov 11 2016, 4:20 PM

Yeah, this is a known issue… :/

	uw.controller.Details.prototype.submit = function () {
		…
		// No way to restore this later... We don't handle partially-successful uploads very well
		this.removeCopyMetadataFeature();
		…
	};

I think this should be actually fairly easy to fix now, after rEUWI5ce17bd10096: Allow cancelling an upload on the "Details" step made it possible to dynamically remove/add the metadata copier.

Restricted Application added a subscriber: Matanya. · View Herald TranscriptNov 11 2016, 7:41 PM

Change 321663 had a related patch set uploaded (by Matthias Mullie):
Add "copy all fields" feature again after having failed to submit

https://gerrit.wikimedia.org/r/321663

Change 321663 merged by jenkins-bot:
Add "copy all fields" feature again after having failed to submit

https://gerrit.wikimedia.org/r/321663

matmarex closed this task as Resolved.Nov 16 2016, 6:19 PM
matmarex removed a project: Patch-For-Review.

The fix should be deployed to Wikimedia wikis next week, per the usual schedule. Thanks for filing a bug!