Page MenuHomePhabricator

[Regression pre-wmf.3] VE crashes with error "Uncaught TypeError: Cannot read property 'setValue' of undefined" while trying to add a code block or while trying to edit a references list
Closed, ResolvedPublic1 Estimate Story Points

Description

Steps to reproduce:

Try to add a code block or Edit an existing references list from VE

Observed Result:

  1. The dialog for adding code block doesnt appear, neither the dialog to edit References list
  2. There is an error in the console for both cases: Uncaught TypeError: Cannot read property 'setValue' of undefined
  1. Cannot save the page after that.

Details

Related Gerrit Patches:
mediawiki/extensions/SyntaxHighlight_GeSHi : masterVE: Fix combobox API and other issues
mediawiki/extensions/Cite : masterUpdate ComboBoxInputWidget API

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 11 2016, 11:03 PM
Ryasmeen updated the task description. (Show Details)Nov 11 2016, 11:14 PM

Change 321691 had a related patch set uploaded (by Esanders):
VE: Fix combobox API and other issues

https://gerrit.wikimedia.org/r/321691

Change 321695 had a related patch set uploaded (by Esanders):
Update ComboBoxInputWidget API

https://gerrit.wikimedia.org/r/321695

Jdforrester-WMF closed this task as Resolved.Nov 15 2016, 5:33 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF set the point value for this task to 1.

Caused by the combobox breaking change in OOUI (two different things to fix). Fun.

Change 321695 merged by jenkins-bot:
Update ComboBoxInputWidget API

https://gerrit.wikimedia.org/r/321695

Change 321691 merged by jenkins-bot:
VE: Fix combobox API and other issues

https://gerrit.wikimedia.org/r/321691