Page MenuHomePhabricator

Amend deletion summary on deletions performed by FuzzyBot
Closed, ResolvedPublic

Description

(Part of translation page "Template:Privacy policy talk header/de-formal".: never contained a translation)

The dot before the colon (.:) is not correct as it is not an abreviation. We should remove that dot.

Details

Related Gerrit Patches:
mediawiki/extensions/Translate : masterRemove dots (.) on pt-*-logreason messages

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 12 2016, 10:50 AM
MarcoAurelio triaged this task as Lowest priority.Nov 12 2016, 10:51 AM

Trivial thing.

Change 321100 had a related patch set uploaded (by MarcoAurelio):
Remove dots (.) on pt-*-logreason messages

https://gerrit.wikimedia.org/r/321100

(Report)
Regression

Wikibase\Test\Repo\Api\ApiXmlFormatTest.testSetDescriptionXmlFormat (from Wikibase_Test_Repo_Api_ApiXmlFormatTest)

Failing for the past 1 build (Since Failed#81897 )
Took 0.11 sec.

Stacktrace

Wikibase\Test\Repo\Api\ApiXmlFormatTest::testSetDescriptionXmlFormat
UsageException: You do not have the permissions needed to carry out this action. (You do not have sufficient permissions)

/srv/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/includes/api/ApiBase.php:1580
/srv/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Wikidata/extensions/Wikibase/repo/includes/Api/ApiErrorReporter.php:272
/srv/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Wikidata/extensions/Wikibase/repo/includes/Api/ApiErrorReporter.php:252
/srv/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Wikidata/extensions/Wikibase/repo/includes/Api/ModifyEntity.php:292
/srv/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Wikidata/extensions/Wikibase/repo/tests/phpunit/includes/Api/ApiXmlFormatTest.php:334
/srv/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Wikidata/extensions/Wikibase/repo/tests/phpunit/includes/Api/ApiXmlFormatTest.php:110
/srv/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/tests/phpunit/MediaWikiTestCase.php:392
/srv/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/maintenance/doMaintenance.php:111

@siebrand @Nikerabbit @hoo: What's that suposed to mean? Syntax/Typo in the code or something else?

Nemo_bis renamed this task from Ammend deletion summary on deletions performed by FuzzyBot to Amend deletion summary on deletions performed by FuzzyBot.Nov 14 2016, 2:27 PM

Change 321100 merged by Nikerabbit:
Remove dots (.) on pt-*-logreason messages

https://gerrit.wikimedia.org/r/321100

Change 321100 merged by Nikerabbit:

@Nikerabbit: Thanks. Hope that merging a change with this failing test does not mean that all of the next patches fail as well.

MarcoAurelio closed this task as Resolved.Nov 14 2016, 2:54 PM