Page MenuHomePhabricator

Kazakh Wikipedia doesn't opened on Firebox browser
Closed, InvalidPublic

Assigned To
None
Authored By
Arystanbek
Nov 14 2016, 2:16 AM
Referenced Files
F4723554: Recording #5.gif
Nov 14 2016, 7:25 AM
F4723397: Aw Snap error.png
Nov 14 2016, 5:50 AM
F4723312: Firebox version.png
Nov 14 2016, 4:54 AM
F12: project.png
Nov 14 2016, 2:42 AM
F4723092: Recording #4.gif
Nov 14 2016, 2:16 AM

Description

Kazakh Wikipedia crashed. Please help us.

Recording #4.gif (480×878 px, 653 KB)
.

Event Timeline

Works for me. Is still reproducible? Try reloading with CTRL + SHIFT + R to bypass any local cache.

A good way to diagnose would be to hit F12, then select the "network" tab, and now refresh the page. Select the first element of the list (on the developer tools console of the network tab) and at the right panel, select "unprocessed headers" (or similar in your language), and copy&paste the response ones.

Works for me in Firefox 49.0.2 on OS X.
What browser version are you using (Help > About Firefox if you don't use a localized version)?

There's a script error ReferenceError: wgULS is not defined – but it doesn't stop the site from returning a blank screen.

@Volker_E I'm using now lastest english language version (Firefox 49.0.2)

Firebox version.png (328×655 px, 58 KB)

Some distro, like Debian Sid (unstable), uses Firefox ESR (extended support), currently at 45.4. Can't repro on this browser.

@Arystanbek How many users are affected? If a few, a gadget or a common.js/vector.js/monobook.js in user pages could be the source.

@Dereckson I asked active users on kkwiki, they are using Google Chrome. I can't use Google Chrome since few months.

Aw Snap error.png (562×1 px, 20 KB)
.

Open a private browsing tab (ctrl + shift p).

Go to kk.wikipedia.org without logging in. Does it work?

If so, there are two methods to find the issue cause:

  1. by dichotomy: you need to go to your settings, disable all the gadgets you use/custom JS code, confirm it works again, reenable half of them: if it still works, the issue is in the other half, it if fails again, the issue is in the part your reenabled
  1. through the JavaScript console: ctrl + maj + k, note any error (error are in red, orange elements aren't errors but warning, including the wgULS ReferenceError)

@Dereckson I have seen only one red line, please see this screencast:

Recording #5.gif (24 MB)

Ciencia_Al_Poder lowered the priority of this task from High to Medium.Nov 14 2016, 4:39 PM

@Dereckson I have seen only one red line, please see this screencast:

So the wiki is now loading for you. Is the issue solved now?