Page MenuHomePhabricator

Technical Collaboration quarterly check in for January – March 2017
Closed, ResolvedPublic

Description

Here we discuss the Technical Collaboration team quarterly goals for January - March 2017 -- see Where to find quarterly goals?

Goals agreed are documented on https://meta.wikimedia.org/wiki/Technical_Collaboration/Goals

Team quarterly goals

Towards annual goal Continue Community liaison support for Foundation Product goals

Towards annual goal Create a systematic approach to community engagement for product development teams

Towards annual goal Connect free software developers with the 2016 Community Wishlist Survey

Individual quarterly goals

OwnerGoals
@CKoerner_WMFT154525: Support Q3 Discovery goal: Prototype and test overhaul UI of search page , T144512: Support Discovery Q2 Goal: Increase maps and graphs usage on Wikipedia (continued), T154630: Inform Stage 0 communities of upcoming Page Previews rollout, T154631: Gather community feedback for Page Previews stage 1 rollouts, T154633: Inform stage 1 communities of upcoming Page Previews rollout, T156659: Review "Wikimedia Foundation Technology and Product Q&A" from Dev Summit and create tasks to address
@ElitreT154320: Support the Parsing team with ongoing changes, T154321: Figure out how to deal with the "Internal Roles, Responsibilities and Interactions" problem between CLs and PMs, T155646: Hire a Community Liaison for the Structured Data project, T155284: Connect other WMF staff and affiliate staff in similar roles with Technical Collaboration
@JohanT153195: Figure out how to make Tech News better, T153208: 2016 Community Wishlist: Report back with analysis and discussions
@KeeganT144625: First review of the Technical Collaboration Guidance by Foundation Product teams and most active technical volunteers, T152515: Pilot the TCG with a product/product team/community liaison
@RfarrandT141926: Wikimedia Developer Summit 2017, T153997: Open call for hosts for Wikimedia Hackathon 2018, T153996: Wikimedia Developer Summit 2017: Feedback Survey , T155597: Wikimedia Developer Summit 2017 Debrief(s)
@QgilT153007: Technical Collaboration annual plan FY2017-18, T132499: Review KPIs, workflows, and scorecards of the Technical Collaboration team, T131689: Second iteration of the Technical Collaboration strategy
@QuiddityT149625: Nick's work with Movement Strategy pages, T155663: Update the Product Documentation help pages, T136866: Improve the per-programming-language listings for our tools
@srishakatuxT154988: Promote a selection of Community Wishlist Survey 2016 projects well suited for volunteer developers, T150732: Provide a group chat system for mentoring, T155387: Organize the first Developer Wishlist survey, T147955: Organize unconference at the Wikimedia Developer Summit 2017
@Trizek-WMFT137796: Help to define next steps concerning Flow development, based on the Flow Satisfaction Survey, T143470: Ask communities which have allowed Flow trials with manual enabling to switch to Beta feature activation, T146972: Announce and follow up with communities about the New Filters for Recent changes Beta deployment, T146669: Create dedicated pages for ERI Recent Changes Beta project
@Whatamidoing-WMFT137317: Inform communities about planned outages caused by the server switch (April&May 2017), T145529: Support the VisualEditor team with the "Iterate on the New Wikitext Editor Beta Feature" goal
@AklapperWork towards consolidation of Tech Community Metrics: T137997: Visualization/data regressions after moving from korma.wmflabs.org to wikimedia.biterg.io, T28: Decide on wanted metrics for Maniphest in kibana, T132421: Identify Wikimedia's most important/used info panels in korma.wmflabs.org.

Calendar

  • 2016-11-15: WMF Product teams are expected to start drafting and discussing their next quarterly goals.
  • 2016-12-09: Q2 team goals due by this date.
  • 2016-12-23: Individual goals agreed and documented here.
  • 2017-01-18: October - December quarterly check in dry run.
  • 2017-04-??: quarterly check in materials must be completed.
  • 2017-04-??: quarterly check in dry run.
  • 2017-04-??: Community Engagement quarterly check in.

Related Objects

Mentioned Here
T28: Decide on wanted metrics for Maniphest in kibana
T132421: Identify Wikimedia's most important/used info panels in korma.wmflabs.org
T137997: Visualization/data regressions after moving from korma.wmflabs.org to wikimedia.biterg.io
T146705: Support rollout of editing wikidata descriptions on Android
T156689: Discuss CSS storage options with community
T156659: Review "Wikimedia Foundation Technology and Product Q&A" from Dev Summit and create tasks to address
T154630: Inform Stage 0 communities of upcoming Page Previews rollout
T154631: Gather community feedback for Page Previews stage 1 rollouts
T154633: Inform stage 1 communities of upcoming Page Previews rollout
T155284: Connect other WMF staff and affiliate staff in similar roles with Technical Collaboration
T153996: Wikimedia Developer Summit 2017: Feedback Survey
T153997: Open call for hosts for Wikimedia Hackathon 2018
T155597: Wikimedia Developer Summit 2017 Debrief(s)
T155387: Organize the first Developer Wishlist survey
T152515: Pilot the TCG with a product/product team/community liaison
T147955: Organize unconference at the Wikimedia Developer Summit 2017
T150732: Provide a group chat system for mentoring
T154988: Promote a selection of Community Wishlist Survey 2016 projects well suited for volunteer developers
T136866: Improve the per-programming-language listings for our tools
T149625: Nick's work with Movement Strategy pages
T155663: Update the Product Documentation help pages
T155646: Hire a Community Liaison for the Structured Data project
T144512: Support Discovery Q2 Goal: Increase maps and graphs usage on Wikipedia
T154525: Support Q3 Discovery goal: Prototype and test overhaul UI of search page
T154320: Support the Parsing team with ongoing changes
T154321: Figure out how to deal with the "Internal Roles, Responsibilities and Interactions" problem between CLs and PMs
T131689: Second iteration of the Technical Collaboration strategy
T141926: Wikimedia Developer Summit 2017
T143166: Identify features promoting contributions from mobile readers that would be welcomed by experienced editors to diversify reach
T144625: First review of the Technical Collaboration Guidance by Foundation Product teams and most active technical volunteers
T153007: Technical Collaboration annual plan FY2017-18
T137796: Help to define next steps concerning Flow development, based on the Flow Satisfaction Survey
T143470: Ask communities which have allowed Flow trials with manual enabling to switch to Beta feature activation
T146669: Create dedicated pages for ERI Recent Changes Beta project
T146972: Announce and follow up with communities about the New Filters for Recent changes Beta deployment
T153195: Figure out how to make Tech News better
T153208: 2016 Community Wishlist: Report back with analysis and discussions
T137317: Inform communities about planned outages caused by the server switch (April&May 2017)
T142645: Announce the new 2017 wikitext editor
T145529: Support the VisualEditor team with the "Iterate on the New Wikitext Editor Beta Feature" goal
T146757: Begin conversation with community on move from OCG to Electron
T132499: Review KPIs, workflows, and scorecards of the Technical Collaboration team

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 14 2016, 2:28 PM
Qgil updated the task description. (Show Details)Nov 14 2016, 8:36 PM
Qgil raised the priority of this task from Normal to High.Nov 25 2016, 8:58 AM
Qgil updated the task description. (Show Details)
Qgil added subscribers: srishakatux, CKoerner_WMF, Johan and 6 others.
Qgil updated the task description. (Show Details)Nov 25 2016, 9:09 AM
Qgil updated the task description. (Show Details)
Elitre updated the task description. (Show Details)Nov 25 2016, 10:13 AM
Qgil updated the task description. (Show Details)Nov 25 2016, 12:40 PM
Qgil added a comment.Nov 25 2016, 12:58 PM

FYI I am thinking of a way to combine quarterly goals and their reviews under m:Technical Collaboration. The Foundation is moving toward a Quarterly Check In model where reviews of the previous quarter and goals of the next are explain together. I want to reflect that in our documentation, bringing the rest of our data to the mix, since they are also updated on a quarterly basis (related to T132499: Review KPIs, workflows, and scorecards of the Technical Collaboration team).

Moushira updated the task description. (Show Details)Nov 26 2016, 1:45 PM
Moushira updated the task description. (Show Details)
Qgil renamed this task from Technical Collaboration quarterly goals for January - March 2017 to Technical Collaboration quarterly check in for January - March 2017.Nov 28 2016, 8:35 AM
Qgil updated the task description. (Show Details)
Johan updated the task description. (Show Details)Dec 14 2016, 5:05 PM
Johan renamed this task from Technical Collaboration quarterly check in for January - March 2017 to Technical Collaboration quarterly check in for January – March 2017.
Johan updated the task description. (Show Details)
Elitre updated the task description. (Show Details)Dec 15 2016, 6:01 PM
Trizek-WMF updated the task description. (Show Details)Dec 20 2016, 11:48 AM
Qgil updated the task description. (Show Details)Dec 21 2016, 10:27 AM
Elitre updated the task description. (Show Details)EditedDec 30 2016, 2:15 PM

I left out something else I want to do because I don't think private tasks are welcome (we will be able to talk about this work soon of course, just not today).

For the records, you can add access restricted task IDs as they won't be links for anyone who cannot access them.

CKoerner_WMF updated the task description. (Show Details)Jan 3 2017, 10:03 PM
Aklapper updated the task description. (Show Details)Jan 4 2017, 5:33 PM
CKoerner_WMF updated the task description. (Show Details)Jan 17 2017, 8:23 PM
Elitre updated the task description. (Show Details)Jan 18 2017, 6:43 PM
Quiddity updated the task description. (Show Details)Jan 18 2017, 7:49 PM
srishakatux updated the task description. (Show Details)Jan 18 2017, 10:32 PM
srishakatux updated the task description. (Show Details)
Qgil added a comment.Jan 20 2017, 1:16 PM

Everything is ready for the Quarterly Check In next Monday.

Keegan updated the task description. (Show Details)Jan 23 2017, 9:11 PM
srishakatux updated the task description. (Show Details)Jan 24 2017, 2:41 AM
Qgil updated the task description. (Show Details)Jan 24 2017, 1:46 PM
Qgil lowered the priority of this task from High to Normal.Jan 24 2017, 1:50 PM

The team goals and half of the individual goals are confirmed. I am hoping to have all the individual goals decided by the end of January.

Rfarrand updated the task description. (Show Details)Jan 26 2017, 12:40 AM
Rfarrand updated the task description. (Show Details)

I added mine, whats with the check marks in front of some people's names?

Qgil added a comment.Jan 27 2017, 10:46 AM

Those check marks mean that the goals have been reviewed and agreed.

Elitre updated the task description. (Show Details)Jan 27 2017, 10:50 AM
CKoerner_WMF updated the task description. (Show Details)Jan 30 2017, 6:14 PM
CKoerner_WMF updated the task description. (Show Details)Jan 30 2017, 6:56 PM
Moushira updated the task description. (Show Details)Jan 30 2017, 10:15 PM
Moushira updated the task description. (Show Details)
Moushira updated the task description. (Show Details)Jan 30 2017, 10:17 PM
Qgil updated the task description. (Show Details)Jan 31 2017, 7:07 AM
Aklapper updated the task description. (Show Details)Jan 31 2017, 9:05 PM
Qgil updated the task description. (Show Details)Feb 22 2017, 10:48 AM
Qgil moved this task from January to February on the Community-Relations-Support (Jan-Mar 2017) board.
Qgil moved this task from January to February on the Developer-Advocacy (Jan-Mar-2017) board.
Aklapper updated the task description. (Show Details)Apr 20 2017, 2:58 PM
Qgil closed this task as Resolved.May 3 2017, 9:16 AM

Slides and minutes of the quarterly check-in meeting hosted on April 17th.

And with this, this task is completed.