Page MenuHomePhabricator

Linter: Improve sorting
Open, Needs TriagePublic

Description

From T148583#2813012:

  • Is linter_id really how users would want us to sort this? (I suppose dba's don't like the idea of denormalizing page_title into the linter table just for the purpose of sorting? However, even just sorting by (namespace,linter_id) seems like it would be a more useful order)

Event Timeline

Legoktm created this task.Nov 22 2016, 3:25 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 22 2016, 3:25 AM
Izno added a subscriber: Izno.EditedAug 23 2017, 2:38 PM

The dropdown filter allowing me to select by namespace is sufficient for sorting purposes IMO.

It might be reasonably to default sort to the cause of the problem i.e. the offending text.

Where the problem is caused might also be preferable. Errors without templates involved are usually simpler to solve, so these would be just as much targets for easy fixes as taking several hours to read through the arcane syntax of wikitext programming (but are sometimes as lengthy in time due to simple magnitude).

ssastry closed this task as Resolved.Aug 23 2017, 5:35 PM
ssastry assigned this task to Legoktm.
ssastry added a subscriber: ssastry.

We now have some sorting. Plus we have T170874: Provide additional Linter statistics about template-generated issues that tracks the issue of providing stats separately for templates and non-templates.

Re Izno's point about templates: There are three possibilities:

  1. The error is in the template: Using LintHint, if the template is written without template-specific markup such as triple curly braces, #if constructions, etc., these are as easy to solve as any other lint errors.
  2. The error is in the page calling the template, in wikitext within a template's parameters, or between an opening and closing template: Using LintHint, these are usually as easy to solve as if the template is not involved at all. In some cases, one has to temporarily insert a space between the opening curly braces of the opening template in order to force LintHint to be able to find the exact location inside.
  3. The error is caused by the interaction of the main page and the template: Here, Izno is right, these can be difficult, especially if the template has template-specific markup. However, I haven't found many lint errors of this type.

With this in mind, I wouldn't find it useful to sort by errors without templates vs. errors with templates. Izno and other users might value this capability.

More useful than sorting, but perhaps more work, would be searching or selecting. We can already select by namespace. It would be great if we could select by "last edited by [user]" or "last edited within X hours or days". In the case of bogus file options, it would be great if we could select by file option; sometimes I want to fix just misspellings of the word "right", or blank options. I have no idea how much effort would be involved with any of these ideas and if they are worth the trouble to code.

It would be helpful if articles were sorted in order of when most recently edited, probably in order of most recently edited last. That way, if one can easily find the new additions/modifications for any type of lint, with or without namespace filter. This is particularly helpful for users who don't use LintHint, edit an article, go to page information, find that there are still errors, and want to work on the remaining errors. I have had experiences of editing an article, verifying from page information that the lint errors had been updated, going to a lint error page for a remaining type of lint error, and not finding the page I had worked on listed among the last 5,000 or even 10,000 errors. This problem would not go away by waiting minutes or hours. Things are sorted approximately in order of when last reviewed by the linter, but I have had experiences where this sort didn't work. I don't care so much about this any more, because I use LintHint, which enables me to find and remove errors of all types in one edit session.

Legoktm reopened this task as Open.Dec 7 2017, 8:17 AM
Legoktm removed Legoktm as the assignee of this task.
He7d3r added a subscriber: He7d3r.Dec 28 2017, 1:09 PM