Loading jquery.ui.draggable triggers deprecation warnings
Open, Needs TriagePublic

Description

When using the jquery.ui.draggable module loaded by the ResourceLoader ( e.g. in the RevisionSlider or WikiEditor extensions ) it triggers deprecation warnings on the JavaScript console.

This page is using the deprecated ResourceLoader module "jquery.ui.widget".
This page is using the deprecated ResourceLoader module "jquery.ui.core". Please use "mediawiki.ui.button" or "oojs-ui" instead.

Any help fixing this is appreciated.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 24 2016, 2:29 PM
WMDE-Fisch updated the task description. (Show Details)
Tobi_WMDE_SW renamed this task from Loading jquery.ui.draggable trigger deprecation warnings to Loading jquery.ui.draggable triggers deprecation warnings.Nov 24 2016, 3:55 PM
Tobi_WMDE_SW moved this task from Incoming to Revision Slider on the TCB-Team board.
Tobi_WMDE_SW moved this task from Incoming to Doing on the Revision-Slider board.Nov 26 2016, 9:37 AM
Krinkle added a subscriber: Krinkle.

(Removing ResourceLoader tag, ResourceLoader is the framework for defining and loading modules - it is not concerned with individual modules such as jquery.ui or oojs-ui.)

AS added a subscriber: AS.Mar 5 2017, 10:53 AM
Krinkle removed a subscriber: Krinkle.Mar 6 2017, 7:50 PM