Page MenuHomePhabricator

Exporting pages fails
Closed, InvalidPublic

Description

Author: tathagata.dasgupta

Description:
I'm using MediaWiki 1.9.3 with The SAINT WAMP Version: 3.4.0 Platforms:Win32(NT/2000/XP/2003) that uses APACHE v2.0.50 PHP v5.0.0 + PECL Extensions and MySQL v4.0.20d.
When I try to export pages in my setup, it gives the following error in Firefox 2.0.0.11

XML Parsing Error: not well-formed
Location: http://10.177.150.183/wiki/index.php/Special:Export
Line Number 1, Column 1:

�\x08
^

and in Internet Explorer 6.0

The XML page cannot be displayed
Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later.


An invalid character was found in text content. Error processing resource 'http://10.177.150.183/wiki/index.php/Special:Exp...

\x1f\x1f\x1f

Googling took me to http://www.gossamer-threads.com/lists/wiki/mediawiki/121566?page=unread#unread

where

"Tell the wiki-site.com administrators to check their configuration; are
they using mod_gzip or similar in Apache? Is there an automated
gzip-output configuration in PHP?"

gave some hints. Accordingly, I commented out

elseif ( empty( $wgNoOutputBuffer ) ) {
	## Compress output if the browser supports it
	if( !ini_get( 'zlib.output_compression' ) ) @ob_start( 'ob_gzhandler' );
}

from the LocalSettings.php and now everything works fine.

I'm very new to reporting bugs/mailing lists of FOSS projects, if I'm duplicating and already addressed issue, please ignore the n00b's effort, ;)


Version: 1.14.x
Severity: normal
URL: http://test2.wikipedia.org/wiki/Special:Export

Details

Reference
bz13180

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:03 PM
bzimport set Reference to bz13180.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Feb 28 2008, 4:36 AM

Can you deliver an accessible reproducable scenario? MediaWiki has reached a stable 1.13 version and development is ongoing at 1.14alpha. This report is on MediaWiki 1.9.3 and there appear to not be any other open reports of this nature. Suggest to close as WORKSFORME if no reproducable scenario has been delivered in a month.

tathagata.dasgupta wrote:

If I understand correctly, "accessible reproducable scenario" would mean a publicly accessible set up to test this - but, my set up is behind company firewalls. So, resolving this issue as WORKSFORME.

Well, that may be kind of in a hurry :)

You could try and put some (one page or just a few words) in test.wikipedia.org (which runs 1.14alpha) and try to reproduce the error. If you can, we may be able to help you. If you can't, you could try to upgrade to 1.13, as nothing significant changed in export since the release of 1.13. Please reopen the bug if you have been able to reproduce on a current version.

tathagata.dasgupta wrote:

screen shot

Screen shots giving the error.

Attached:

tathagata.dasgupta wrote:

screen shot giving the error

Attached:

tathagata.dasgupta wrote:

The error can be reproduced in the http://test.wikipedia.org/
Please refer to the above screen shots for the input and erroneous output.

Request: POST http://test.wikipedia.org/w/index.php?title=Special:Export&action=submit, from 208.80.152.32 via sq37.wikimedia.org (squid/2.6.STABLE21) to 10.0.2.35 (10.0.2.35)
Error: ERR_ZERO_SIZE_OBJECT, errno [No Error] at Mon, 18 Aug 2008 20:19:08 GMT

CONFIRMED on 1.14alpha (r39353) on
http://test.wikipedia.org/wiki/Special:Export.

Could *not* reproduce on http://nl.wikipedia.org/wiki/Special:Export (same
version) with the same 2 page names (or changing to "Hoofdpagina" and
"Wikipedia:Wat Wikipedia niet is", the Dutch equivalents).

Could *not* reproduce on my local wiki with the same pagenames (1.14 alpha
(r39616) that uses XAMPP pretty standard config with PHP 5.2.5, Apache/2.2.8
(Win32)).

Raised severity and priority.

tathagata.dasgupta wrote:

Just to add http://nl.wikipedia.org/ is powered by MediaWiki 1.14alpha (r39353)
see http://nl.wikipedia.org/wiki/Speciaal:Softwareversie.

a.koppad wrote:

I could not reproduce the error on
http://test2.wikipedia.org/wiki/Special:Export.

Could not reproduce this error on http://nl.wikipedia.org/wiki/Special:Export as well.

Anu: Which browser did you use, and which exact steps did you perform?

Same error discovered. Steps:

  1. Went to URL provided
  2. Added file from "test" category
  3. Clciked "Export"

Update: Version: 1.25wmf11 (2837116)

TTO added a subscriber: TTO.Dec 13 2014, 2:31 AM

Thanks for the triage.

Same error discovered. Steps:

  1. Went to URL provided

Which URL exactly?

  1. Added file from "test" category

Which file exactly?

  1. Clciked "Export"
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 7 2017, 11:30 PM
Zoranzoki21 closed this task as Invalid.Sep 29 2018, 10:26 PM
Zoranzoki21 added a subscriber: Zoranzoki21.

Closing.. Task is very old. Internet Explorer 6.0, MediaWiki 1.14.x are not supported. This task is opened before 10 years.

Dinoguy1000 updated the task description. (Show Details)Sep 30 2018, 3:24 AM