Page MenuHomePhabricator

[Regression pre-wmf.5] Searching for templates in VE throws error "Uncaught TypeError: this.getApi is not a function"
Closed, ResolvedPublic1 Estimated Story Points

Description

Searching for templates in VE from Insert>Template throws error "Uncaught TypeError: this.getApi is not a function"

Event Timeline

Ryasmeen created this task.Dec 1 2016, 10:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 1 2016, 10:43 PM

Change 324823 had a related patch set uploaded (by Alex Monk):
Use widget.getApi, not this.getApi

https://gerrit.wikimedia.org/r/324823

AlexMonk-WMF added a subscriber: AlexMonk-WMF.

yep. specifically when you get a valid result back. caused by https://gerrit.wikimedia.org/r/#/c/324531/

Jdforrester-WMF renamed this task from Searching for templates in VE throws error "Uncaught TypeError: this.getApi is not a function" to [Regression pre-wmf.5] Searching for templates in VE throws error "Uncaught TypeError: this.getApi is not a function" .Dec 1 2016, 11:27 PM
Jdforrester-WMF closed this task as Resolved.
Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

Change 324823 merged by jenkins-bot:
Use widget.getApi, not this.getApi

https://gerrit.wikimedia.org/r/324823