Page MenuHomePhabricator

CX2: Adapt the reflist template to the corresponding one in the target language
Closed, DeclinedPublic

Description

When adapting a template, Content Translation should use the corresponding template according to Wikidata (dealing with potential errors as described in T192271). Currently Content Translation is not adapting the "reflist" template to the corresponding ones based on Wikidata. For example, Content Tranlsation adapts English Wikipedia's {{Reflist}} to {{Reflist}} in the Polish Wikipedia even though the equivalent template is {{Przypisy}} instead.

To reproduce:

  1. Start translating the article [[Appelate court]] from English to Polish (to user space).
  2. Click the first paragraph.
  3. Publish.

Observe, that the references paragraph at the bottom is automatically translated, and it has a "{{Reflist}}" template. This is wrong: It should be {{Przypisy}}, which is already correctly linked to the English template in Wikidata. The same happens when translating to the Hebrew Wikipedia, too.

Because the references paragraphs are translated particularly often and automatically and the user often don't even notice this, this happens quite often. We may want to check if the issue happens with other templates.

__
This might be a regression of T125579, or another instance of a similar issue. Templates must be adapted only by interlanguage link and never by the same name.

Event Timeline

Amire80 created this task.Dec 3 2016, 2:05 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 3 2016, 2:05 PM
Amire80 moved this task from Needs Triage to Bugs on the ContentTranslation board.Dec 5 2016, 8:13 PM
Arrbee moved this task from Bugs to Check & Move on the ContentTranslation board.Jun 5 2018, 12:03 PM
IKhitron removed a subscriber: IKhitron.Jun 5 2018, 12:05 PM
Pginer-WMF triaged this task as Medium priority.Jun 6 2018, 5:14 PM
Pginer-WMF assigned this task to Amire80.Jul 9 2018, 4:00 PM
Pginer-WMF added a subscriber: Pginer-WMF.

@Amire80, can you confirm whether this happens in version 2 of Content Translation?

I re-checked in production, cx-testing and cx2-testing - everywhere the Reference list will be published as (http://cx2-testing.wmflabs.org/index.php/User:ET3/Appellate_court):

== References ==
{{reflist|30em}}

I re-checked in production, cx-testing and cx2-testing - everywhere the Reference list will be published as (http://cx2-testing.wmflabs.org/index.php/User:ET3/Appellate_court):

== References ==
{{reflist|30em}}

Ok. This means that Content Translation is not adapting the "reflist" template to the corresponding ones based on Wikidata. I'll update the description to capture this and focus the task on solving it on the new version.

Pginer-WMF renamed this task from Content Tranlsation adapts English Wikipedia's {{Reflist}} to {{Reflist}} in the Polish Wikipedia even though it is linked to {{Przypisy}} to CX2: Adapt the reflist template to the corresponding one in the target language.Jul 16 2018, 3:53 PM
Pginer-WMF removed Amire80 as the assignee of this task.
Pginer-WMF updated the task description. (Show Details)

Description says:

To reproduce:

  1. Start translating the article [[Appelate court]] from English to Polish (to user space).
  2. Click the first paragraph.
  3. Publish.

Above is true for CX1 only. References aren't auto-added to the translation in CX2. @Pginer-WMF, do we miss such functionality in CX2?

I re-checked in production, cx-testing and cx2-testing - everywhere the Reference list will be published as (http://cx2-testing.wmflabs.org/index.php/User:ET3/Appellate_court):

== References ==
{{reflist|30em}}

@Etonkovidova, I don't see {{reflist|30em}} in wikitext of the page you linked.
I have tried translating the same page ("Appellate court" from English to Spanish) and here is how references markup turned out to be:

== Referencias ==
<references responsive="0" />

Finally, @KartikMistry, please consider removing abuse filter that easily prevents publishing in main namespace on cx2-testing in many cases. Say we translate from English to Spanish. Category namespace is Categoría in Spanish and abuse filter is preventing publishing, because no categories are recognized as such.

Finally, @KartikMistry, please consider removing abuse filter that easily prevents publishing in main namespace on cx2-testing in many cases. Say we translate from English to Spanish. Category namespace is Categoría in Spanish and abuse filter is preventing publishing, because no categories are recognized as such.

Done. Thanks!

Above is true for CX1 only. References aren't auto-added to the translation in CX2. @Pginer-WMF, do we miss such functionality in CX2?

Yes, that is missing in CX2. I created a ticket to capture it: T200308: CX2: Add reference list automatically

Pginer-WMF closed this task as Declined.Jul 25 2018, 4:53 PM

Currently in production, CX2 creates a reference list, as shown below. This may be because Visual Editor surface "unpacks" the original {{reflist}} template into the resulting Reference list element, which seems convenient in this case given the problems for rendering those templates in visual mode (T53146).