Page MenuHomePhabricator

cronspam cleanup: Cron <root@ms-be2*> test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )
Closed, ResolvedPublic

Description

It seems that the ms-be hosts have recently been spamming the cron with some errors:

2016-11-30:
subject: Cron <root@ms-be2026> test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )
body: run-parts: /etc/cron.monthly/ieee-data exited with return code 1

The same email was sent for many other ms-be hosts, including but not limited to: ms-be1022, ms-be2022, ms-be3004 (so at least one in each of those sites, but really many more).

Creating this task after a quick check with @fgiunchedi via IRC. Please followup and resolve, thanks!

Details

Related Gerrit Patches:
operations/puppet : productionbase: get rid of monthly ieee-data cronjob

Event Timeline

RobH created this task.Dec 5 2016, 7:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 5 2016, 7:14 PM
fgiunchedi triaged this task as Medium priority.Dec 6 2016, 10:27 PM

The problem is that the cronjob require internet access to download an updated out.txt. Also the cronjob itself was removed from versions (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=826104). I'm tempted to set in puppet /usr/bin/update-oui as non-executable if it exists so that the cronjob doesn't run. Upgrading to stretch won't be affected because the script was renamed to update-ieee-data.

Change 325699 had a related patch set uploaded (by Filippo Giunchedi):
swift: get rid of monthly ieee-data cronjob

https://gerrit.wikimedia.org/r/325699

Dzahn added a subscriber: Dzahn.Dec 7 2016, 1:36 AM

The Debian bug says how it was pointless to download this all the time anyways and on top of that it creates a ddos of ieee.org when tons of machines are doing this. Yea, +1 to that patch to disable it.

Change 325699 abandoned by Filippo Giunchedi:
base: get rid of monthly ieee-data cronjob

Reason:
What Faidon suggested (newer ieee-data) makes more sense, I'll do that instead

https://gerrit.wikimedia.org/r/325699

Mentioned in SAL (#wikimedia-operations) [2016-12-08T17:31:05Z] <godog> upload ieee-data 20160613.1 and upgrade jessie machines to it T152440

fgiunchedi closed this task as Resolved.Dec 8 2016, 5:37 PM

Resolving, let's reopen if it happens again in the following months.

A fix for this is pending with the next jessie point release, which will probably be released in January: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=846017