Page MenuHomePhabricator

Create email alias for benefactors@
Closed, InvalidPublic

Description

Hi,

Can you please create an alias for Michael Beattie?

He would like benefactors@wikimedia.org to be sent to benefactors@wikimedia.zendesk.com

Thanks,
Jo

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 7 2016, 11:17 PM
Aklapper renamed this task from Create an Alias to Create email alias for benefactors@.Dec 8 2016, 10:44 AM
CaitVirtue added a subscriber: CaitVirtue.

Hi All -- Can you share an ETA on this? We're triaging a high volume of email to benefactors@ right now via gmail, which is really cumbersome. Getting these messages into ZenDesk is going to make things better for our FR staff and for donors. Thanks!

CaitVirtue triaged this task as Unbreak Now! priority.Dec 9 2016, 11:31 PM
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptDec 9 2016, 11:31 PM

This does not remotely qualify for UBN status. Why should this go to ZenDesk instead of OTRS? Additionally, ETAs are not normally given.

Krenair lowered the priority of this task from Unbreak Now! to Needs Triage.Dec 10 2016, 1:25 PM

The OTRS queue already generally forwards anything donation-related to Zendesk, so this fits with established practice. @Krenair can you explain more about UBN status? Fwd-ing benefactors@ would be a really helpful & important change to Advancement workflow.

Yes, this seems inappropriate for UBN priority for several reasons. At first glance:

  • This is not a bug, it is essentially a feature request (i.e., you are asking for something new)
  • You are the requestor(s), so can't really set it
  • It only affects (a subset of) staff. That's likely not enough people to qualify for 'drop everything else and work on this'

Some of this is at https://www.mediawiki.org/wiki/Phabricator/Project_management#Setting_task_priorities

Apologies if we're not totally up on the standard protocol here and didn't give enough context. This request is in conjunction with the annual fundraiser going on right now, where we experience extremely high volume of messages in a short period of time. We made an adjustment earlier in the year as to how benefactors@ was routed, but it's now clear that the impact of that decision creates a problem with our workflows, and we're asking for assistance routing emails to this address back through ZenDesk. Please let us know if more context or details would be helpful. We still requesting that this change happen ASAP.

I'm not sure if operations will need any more details (and I don't fully understand the mail rules that allow ZenDesk to handle wikimedia mail), this is essentially waiting for one of them to notice the ticket. I'm trying some backchannels for you to see if any ops are around at the weekend (they're likely only responding to pages). Doesn't fundraising have a specific contact in ops for these sorts of things?

DStrine assigned this task to Jgreen.Dec 11 2016, 1:11 AM
DStrine triaged this task as Unbreak Now! priority.
DStrine added a project: fundraising-tech-ops.
DStrine added a subscriber: DStrine.

I'm putting this back to Unbreak Now. This justifies immediate attention at someone's earliest convenience. Major Gifts' needs should be high priority during the English Campaign.

@Jgreen
Are you able to handle this? MG had been talking to OIT. OIT directed them to ops. Any help or information would be great

Krenair lowered the priority of this task from Unbreak Now! to High.Dec 11 2016, 1:56 AM

I'm putting this back to Unbreak Now.

It's not a task that can hold UBN priority. Please at least read what I wrote above.

This justifies immediate attention at someone's earliest convenience. Major Gifts' needs should be high priority during the English Campaign.

Set to high then, but ops can still come along and lower it if they disagree with you...

awight added a subscriber: awight.Dec 11 2016, 2:12 AM

@Krenair wrote,

It only affects (a subset of) staff. That's likely not enough people to qualify for 'drop everything else and work on this'

That's technically incorrect: if MBeat's team can't keep up with their workload because they're stuck using the wrong tool for the job, then we might all be looking for new employment next year.

While we're consulting policy documents rather than fixing a minor bug, let me point out that:

Priority should normally be set by product managers, maintainers, or developers who plan to work on the task, or by the bugwrangler or experienced community members, not by the reporter filing the bug report or by outside observers

I respect your good intentions to protect the Ops team from rando crazies, but I feel like you are an outside observer here, and DStrine is the product manager, whose judgment takes precedence and whose bacon is directly on the line.

If you want to chat more about the Fundraising priority-setting process and how critical Donor Services is to the front-end experience our donors are having right now, please feel free to call me or IRC. Please don't make this task into a revert war or dilute the comments with any more policy.

I'm an experienced community member here, don't bother trying to belittle me that way.

benefactors@ already exists as either an alias or account under the OIT administered part of the system, which preempts the Ops-administered aliases, so I think OIT has to be the one to fix this

We're pursuing a workaround in parallel, simply configuring the Gmail account to forward to Zendesk.

@JGulingan This might be going back to you or someone in IT. We need someone to help clear this up ASAP.

DStrine raised the priority of this task from High to Unbreak Now!.Dec 11 2016, 4:00 PM

@Krenair As far as I can tell you aren't part of ops FR-tech or OIT. Please leave this conversation. Also @awight is right, I'm the person who defines this urgency/priority.

I'm about to start calling ops and OIT on a Sunday. Major Girfts is getting bounced between departments and it's wildly frustrating.

Reedy added a subscriber: Reedy.Dec 11 2016, 4:07 PM

I'm kinda confused when you have a dedicated ops person why you didn't contact them directly before... Or OIT as appropriate

Seems a bit mean filing it on a weekday, not really following up on it, then going OMG FIX IT NOW on the weekend

Reedy added a comment.Dec 11 2016, 4:13 PM

@Krenair As far as I can tell you aren't part of ops FR-tech or OIT. Please leave this conversation. Also @awight is right, I'm the person who defines this urgency/priority.
I'm about to start calling ops and OIT on a Sunday. Major Girfts is getting bounced between departments and it's wildly frustrating.

Also, he may not be FR-tech nor OIT, but I think it's worth pointing out he did try and get you some help about 19 hours ago by asking around in the private ops IRC channels to see if anyone would be able to help you out

Reedy added a comment.Dec 11 2016, 4:17 PM

I'm about to start calling ops and OIT on a Sunday. Major Girfts is getting bounced between departments and it's wildly frustrating.

See Jeffs response -- you need to call OIT, not ops

benefactors@ already exists as either an alias or account under the OIT administered part of the system, which preempts the Ops-administered aliases, so I think OIT has to be the one to fix this

We now have a regular oit ticket and a direct email to the team. I'll see what that does in the next few hours

That's technically incorrect: if MBeat's team can't keep up with their workload because they're stuck using the wrong tool for the job, then we might all be looking for new employment next year.

Speaking of diluting this task with noise, you've decided to inject this task with fear, uncertainty, and doubt ("bacon is on the line!", "unemployment is about to rise!")? Sheesh. You're better than this.

While we're consulting policy documents rather than fixing a minor bug, [...]

It's amusing that you describe this task as minor, when everyone else commenting here is arguing about how this task is super-urgent and super-important. I guess it's both minor and major? What a task!

Hi all,

I didn't know that benefactors@ was an actual account that was in our system. There might be a temporary work around. Since this is an actual gmail account, I was thinking that whoever has ownership of this account can log in and add a forwarding address to that account.

You would have to login to benefactors@, go to settings, then click onto the forwarding tab. There should be a way to add a forwarding address and then it would need confirmation from the address it is being forwarded to.

If no one knows the password to this account, I can reset it.

Best,
Jo

@JGulingan It would be great if you could reset the password for the
account. Once reset, I'll try to log in and add the forwarding address.
Thanks for your help.

eliza added a subscriber: eliza.Dec 11 2016, 10:24 PM

@LeanneS - let me know when you're available so that I may send you the temporary password via Hangouts.

Eliza

@eliza I didn't see your update for this, but I had sent @LeanneS a new password for benefactors@

Great!
Thanks Jo

@eliza and @JGulingan thanks for your help gaining access. The forwarding address is set and it looks like there is just the final step of the confirmation code sent to benefactors@wikimedia.zendesk.com to complete the verification.

eliza added a comment.Dec 12 2016, 2:12 AM

@LeanneS - I believe this is something that @MBeat33 will have to confirm in the Admin Panel of Zendesk, but not 100% sure.

I'd suggest either Michael or you contacting Zendesk Support directly to properly configure Zendesk for you needs. Since you have an Enterprise account reaching out to a Rep may be quicker.

Let me know if you need anything else.

Eliza

Jgreen closed this task as Invalid.Dec 12 2016, 4:09 PM

The task was bounced back to OIT because the account already exists and is under OIT administration.

demon added a subscriber: demon.Dec 14 2016, 7:37 PM

Just a few meta notes about the interactions I saw here because I was asked to weigh in...

  • I think some people were being overly condescending in what was pretty valid criticism over the use of UBN! This wasn't causing a site outage or data loss or a regression--it was just a pretty bad flaw in existing workflow--High would have easily sufficed. Hyperbole and asking people to butt out aren't necessary (NB: comment on the task, not the person)
  • But...if people are going to argue over it, you should just walk away. Statuses aren't that important in the grand scheme of things (tbh, I mostly ignore them as I have an internal idea of status on basically every bug and I think statuses are completely subjective)
  • Raising priority on a Friday and expecting it to get done over the weekend is---slightly odd. I dunno about everyone but I certainly don't start reading Phabricator e-mails about priority changes just as a weekend is starting. There's probably a better venue (e-mailing, IRC) to bring attention to your issue if it's urgent.

Everyone should take a chill pill next time please...this was far more heated than was necessary for something so "minor" and that nobody disagreed needed doing to begin with.

Trout slaps and hugs for everyone ❤️

mmodell removed a subscriber: awight.Jun 22 2017, 9:34 PM