Page MenuHomePhabricator

Menu icons are missing on Firefox 50.0.2, Mac OS 10.9.5
Closed, ResolvedPublic2 Story Points

Description

https://en.m.wikipedia.org/wiki/Main_Page

Timebox: 8hr (if you spend longer than this time bring it back to discussion at standup)

Event Timeline

bmansurov created this task.Dec 8 2016, 9:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 8 2016, 9:58 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson set the point value for this task to 2.
MBinder_WMF triaged this task as High priority.Dec 12 2016, 6:18 PM
bmansurov moved this task from To Do to Doing on the Reading-Web-Sprint-87-♨️😭 board.

Change 326526 had a related patch set uploaded (by Bmansurov):
Remove redundant "prefix" from ResourceLoaderImageModule modules

https://gerrit.wikimedia.org/r/326526

A few observations:

So, the issue is with the production environment whether logged in or out.

I've submitted a patch above which cleans up the icon code, but I don't know if it will fix the issue as the issue is happening in production only.

Pinging, Release-Engineering-Team in case they can help.

I couldn't replicate this on https://en.m.wikipedia.beta.wmflabs.org/wiki/Main_Page as you state.
Whenever I see this, my thoughts immediately turn to MediaWiki:Mobile.css
I ported MediaWiki:Mobile.css to the beta cluster - and of course after doing this the beta cluster was showing the same problem
Bingo: https://en.m.wikipedia.org/wiki/Special:MobileDiff/754478793

Worth an upstream bug @Krinkle ? Seems we could/should lint this css?

bmansurov reassigned this task from bmansurov to ovasileva.Dec 12 2016, 11:53 PM
ovasileva closed this task as Resolved.Dec 14 2016, 8:51 PM