Page MenuHomePhabricator

Fix namespaces in ca.wikiquote
Closed, ResolvedPublic

Description

https://ca.wikiquote.org/wiki/Especial:Redireccions_dobles reports that VD:PMF has "incorrect title". Can someone please run namespaceDupes.php for me to fix it? Thanks.

Event Timeline

Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptDec 9 2016, 6:41 PM

Mentioned in SAL (#wikimedia-operations) [2016-12-09T19:01:52Z] <bd808> Ran mwscript namespaceDupes.php cawikiquote --fix for T152793

bd808 added a subscriber: bd808.Dec 9 2016, 7:02 PM
terbium:~
bd808$ mwscript namespaceDupes.php cawikiquote --fix
id=6681 ns=0 dbk=VD:ADM -> VD-ADM (no conflict)
id=6352 ns=0 dbk=VD:ADMS -> VD-ADMS (no conflict)
id=8469 ns=0 dbk=VD:AJUDA -> VD-AJUDA (no conflict)
id=6920 ns=0 dbk=VD:B -> VD-B (no conflict)
id=6709 ns=0 dbk=VD:CF -> VD-CF (no conflict)
id=7814 ns=0 dbk=VD:CSR -> VD-CSR (no conflict)
id=6353 ns=0 dbk=VD:D -> VD-D (no conflict)
id=6103 ns=0 dbk=VD:E -> VD-E (no conflict)
id=6539 ns=0 dbk=VD:EP -> VD-EP (no conflict)
id=6139 ns=0 dbk=VD:FF -> VD-FF (no conflict)
id=4480 ns=0 dbk=VD:LE -> VD-LE (no conflict)
id=6893 ns=0 dbk=VD:LFF -> VD-LFF (no conflict)
id=6136 ns=0 dbk=VD:NO -> VD-NO (no conflict)
id=6167 ns=0 dbk=VD:NOTI -> VD-NOTI (no conflict)
id=6692 ns=0 dbk=VD:PA -> VD-PA (no conflict)
id=6879 ns=0 dbk=VD:PMF -> VD-PMF (no conflict)
id=6318 ns=0 dbk=VD:PO -> VD-PO (no conflict)
id=6887 ns=0 dbk=VD:PP -> VD-PP (no conflict)
id=6335 ns=0 dbk=VD:PVN -> VD-PVN (no conflict)
id=6676 ns=0 dbk=VD:TU -> VD-TU (no conflict)
id=7633 ns=0 dbk=VD:VE -> VD-VE (no conflict)
id=6107 ns=0 dbk=VD:VER -> VD-VER (no conflict)
id=7065 ns=0 dbk=VD:VR10 -> VD-VR10 (no conflict)
id=8439 ns=0 dbk=VD:VR11 -> VD-VR11 (no conflict)
24 pages to fix, 24 were resolvable.

0 links to fix, 0 were resolvable.

Looks good!
MarcoAurelio closed this task as Resolved.Dec 9 2016, 7:03 PM
MarcoAurelio assigned this task to bd808.
MarcoAurelio moved this task from Backlog to Done on the Wikimedia-Site-requests board.
Restricted Application added a project: User-bd808. · View Herald TranscriptDec 9 2016, 7:04 PM
MarcoAurelio moved this task from To Do to Done on the User-bd808 board.Dec 9 2016, 7:04 PM
MarcoAurelio reopened this task as Open.Dec 9 2016, 7:12 PM
MarcoAurelio triaged this task as Normal priority.
MarcoAurelio moved this task from Done to Backlog on the Wikimedia-Site-requests board.

Hmm, now typing VD:AJUDA redirects you to https://ca.wikiquote.org/wiki/Especial:GoToInterwiki/vd:AJUDA instead to Viquidites:Ajuda.

https://ca.wikiquote.org/wiki/VD:AJUDA says "Incorrect title".

Weird.

MarcoAurelio renamed this task from Fix namespaces in ca.wiktionary to Fix namespaces in ca.wikiquote.Dec 9 2016, 7:15 PM

I think that vd: on the interwiki might be the cause for this issue.

Terbium
$ sql cawikiquote -h db2050
mysql:wikiadmin@db2050 [cawikiquote]> SELECT page_id, page_title FROM page WHERE page_title LIKE 'VD:PMF';
Empty set (0.06 sec)

mysql:wikiadmin@db2050 [cawikiquote]> SELECT page_id, page_title FROM page WHERE page_title LIKE 'PMF';
+---------+------------+
| page_id | page_title |
+---------+------------+
|    9187 | PMF        |
+---------+------------+ 
1 row in set (0.04 sec)

This 9187 is https://ca.wikiquote.org/w/index.php?title=Viquidites:PMF&action=info

So, I think the situation is solved, and double redirect will be cleaned up during next page refresh.

VD:AJUDA still gives incorrect title :-(

I guess it's due to the interwiki vd: still in place. namespaceDupes.php moved the pages VD:xyz to VD-XYZ to avoid the interwiki conflict. Once we have that fixed, we can move them back. Can a script be tasked with doing that?

Fix what exactly? We need this vd: interwiki for Vikidia, I'd recommend to
not use anymore a VD: namespace alias.

vikidia works as well for linking to fr.wikidia. And again, VD: is not a
namespace alias for ca.wikiquote, which has none configured. That interwiki
causes ns:0 pages to conflict in this project. Either we set VD: as
NamespaceAliases for ca.wikiquote or we remove vd: entirely from the
interwiki map. Can you count how many instances of vd: are being used on
the projects to see if removing vd: is acceptable?

@Linedwell could you give us some input, feedback and stats about Vikidia vd: links current use?

@Dereckson I think using vd: for Vikidia links is more relevant than using it for just one namespace redirection on a single project, Vikidia exists in 8 languages and so could be usefull more globally than a local namespace redirect. Furthermore, all Vikidia versions could be reached with the single vd: interlink (i.e. using Vikidia's interwiki table, vd:ca: would redirect to the catalan Vikidia)

bd808 moved this task from Done to Archive on the User-bd808 board.Jan 7 2017, 12:20 AM