Page MenuHomePhabricator

Notices and Alerts on Wikipedia Arabic cannot be opened (TypeError: transformTable is undefined)
Closed, ResolvedPublic

Description

Hi ,

Starting from yesterday a problem have raised in Arabic Wikipedia.

Users in Different countries can't open open their Notices and their Alerts on ar. wiki, but they can in other projects.

Is there any solution?

Event Timeline

Bachounda created this task.Dec 9 2016, 8:27 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 9 2016, 8:27 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptDec 9 2016, 8:34 PM
Aklapper renamed this task from Big problem Notices and Alerts in Wikipedia Arabic to Notices and Alerts on Wikipedia Arabic cannot be opened (TypeError: transformTable is undefined).Dec 9 2016, 8:36 PM
Aklapper triaged this task as Unbreak Now! priority.
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptDec 9 2016, 8:36 PM

Hi @Bachounda! Thanks for reporting this!

Posting the output of the web browser's developer tools' 'console' here.
(For more information see: Firefox ≥24; Internet Explorer; Google Chrome; Apple Safari)

Exception in module-execute in module ext.uls.compactlinks:  load.php:176:576
TypeError: transformTable is undefined TypeError: transformTable is undefined
Stack trace:
[object Object]  load.php:176:614
	logError https://ar.wikipedia.org/w/load.php:176:614
	handler https://ar.wikipedia.org/w/load.php:154:965
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:45:104
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:46:431
	jQuery.Callbacks/self.fire https://ar.wikipedia.org/w/load.php:46:474
	mw.track https://ar.wikipedia.org/w/load.php:154:747
	execute/runScript/< https://ar.wikipedia.org/w/load.php:161:860
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:45:104
	jQuery.Callbacks/self.add https://ar.wikipedia.org/w/load.php:45:656
	.Deferred/promise.always https://ar.wikipedia.org/w/load.php:46:865
	execute/runScript https://ar.wikipedia.org/w/load.php:161:514
	execute/</checkCssHandles https://ar.wikipedia.org/w/load.php:162:241
	execute/</cssHandle/< https://ar.wikipedia.org/w/load.php:162:371
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:45:104
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:46:431
	jQuery.Callbacks/self.fire https://ar.wikipedia.org/w/load.php:46:474
	fireCallbacks https://ar.wikipedia.org/w/load.php:156:505
	addEmbeddedCSS https://ar.wikipedia.org/w/load.php:157:99
	addEmbeddedCSS/cssBufferTimer< https://ar.wikipedia.org/w/load.php:156:723
TypeError: transformTable is undefined  load.php:278:600
	.convertNumber https://ar.wikipedia.org/w/load.php:278:600
	mw.echo.ui.NotificationBadgeWidget.prototype.updateBadge https://ar.wikipedia.org/w/load.php:96:609
	oo.EventEmitter.prototype.emit https://ar.wikipedia.org/w/load.php:339:836
	mw.echo.dm.ModelManager.prototype.setNotificationModels https://ar.wikipedia.org/w/load.php:22:578
	mw.echo.Controller.prototype.fetchLocalNotifications/< https://ar.wikipedia.org/w/load.php:7:80
	.Deferred/promise.then/</</< https://ar.wikipedia.org/w/load.php:47:126
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:45:104
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:46:431
	.Deferred/promise.then/</</< https://ar.wikipedia.org/w/load.php:47:297
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:45:104
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:46:431
	.Deferred/</deferred[tuple[0]] https://ar.wikipedia.org/w/load.php:47:765
	mw.echo.api.PromisePrioritizer.prototype.setSuccess/< https://ar.wikipedia.org/w/load.php:65:1020
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:45:104
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:46:431
	.Deferred/</deferred[tuple[0]] https://ar.wikipedia.org/w/load.php:47:765
	mw.Api.prototype.ajax/xhr< https://ar.wikipedia.org/w/load.php:253:258
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:45:104
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:46:431
	done https://ar.wikipedia.org/w/load.php:135:757
	.send/callback https://ar.wikipedia.org/w/load.php:141:562

And now with ?debug=true for more useful output on https://ar.wikipedia.org/wiki/الصفحة_الرئيسية?debug=true :

TypeError: transformTable is undefined  mediawiki.language.numbers.js:228:1
	.convertNumber https://ar.wikipedia.org/w/resources/src/mediawiki.language/mediawiki.language.numbers.js:228:1
	CompactInterlanguageList.prototype.addTrigger https://ar.wikipedia.org/w/extensions/UniversalLanguageSelector/resources/js/ext.uls.compactlinks.js:489:5
	CompactInterlanguageList.prototype.render https://ar.wikipedia.org/w/extensions/UniversalLanguageSelector/resources/js/ext.uls.compactlinks.js:107:3
	CompactInterlanguageList.prototype.init https://ar.wikipedia.org/w/extensions/UniversalLanguageSelector/resources/js/ext.uls.compactlinks.js:93:3
	createCompactList https://ar.wikipedia.org/w/extensions/UniversalLanguageSelector/resources/js/ext.uls.compactlinks.js:501:3
	<anonymous> https://ar.wikipedia.org/w/extensions/UniversalLanguageSelector/resources/js/ext.uls.compactlinks.js:507:3
	<anonymous> https://ar.wikipedia.org/w/extensions/UniversalLanguageSelector/resources/js/ext.uls.compactlinks.js:22:3

TypeError: transformTable is undefined  mediawiki.language.numbers.js:228:1
	.convertNumber https://ar.wikipedia.org/w/resources/src/mediawiki.language/mediawiki.language.numbers.js:228:1
	mw.echo.ui.NotificationBadgeWidget.prototype.updateBadge https://ar.wikipedia.org/w/extensions/Echo/modules/ui/mw.echo.ui.NotificationBadgeWidget.js:261:23
	oo.EventEmitter.prototype.emit https://ar.wikipedia.org/w/resources/lib/oojs/oojs.jquery.js:775:5
	mw.echo.dm.ModelManager.prototype.setNotificationModels https://ar.wikipedia.org/w/extensions/Echo/modules/model/mw.echo.dm.ModelManager.js:173:3
	mw.echo.Controller.prototype.fetchLocalNotifications/< https://ar.wikipedia.org/w/extensions/Echo/modules/controller/mw.echo.Controller.js:349:6
	.Deferred/promise.then/</</< https://ar.wikipedia.org/w/load.php:3305:30
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:3148:10
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:3260:7
	.Deferred/promise.then/</</< https://ar.wikipedia.org/w/load.php:3312:10
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:3148:10
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:3260:7
	.Deferred/</deferred[tuple[0]] https://ar.wikipedia.org/w/load.php:3350:5
	mw.echo.api.PromisePrioritizer.prototype.setSuccess/< https://ar.wikipedia.org/w/extensions/Echo/modules/api/mw.echo.api.PromisePrioritizer.js:60:5
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:3148:10
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:3260:7
	.Deferred/</deferred[tuple[0]] https://ar.wikipedia.org/w/load.php:3350:5
	mw.Api.prototype.ajax/xhr< https://ar.wikipedia.org/w/resources/src/mediawiki/api.js:267:7
	jQuery.Callbacks/fire https://ar.wikipedia.org/w/load.php:3148:10
	jQuery.Callbacks/self.fireWith https://ar.wikipedia.org/w/load.php:3260:7
	done https://ar.wikipedia.org/w/load.php:9314:5
	.send/callback https://ar.wikipedia.org/w/load.php:9718:8
Restricted Application added a project: UniversalLanguageSelector. · View Herald TranscriptDec 9 2016, 8:43 PM

thanks @Aklapper for the quick reaction !
add to this, the same problem has detected on other arabic projects.
What we should we do now ?

Change 326175 had a related patch set uploaded (by Catrope):
Follow-up e8dd1f43fb169: fix JS error when $wgTranslateNumerals is false

https://gerrit.wikimedia.org/r/326175

Change 326175 merged by jenkins-bot:
Follow-up e8dd1f43fb169: fix JS error when $wgTranslateNumerals is false

https://gerrit.wikimedia.org/r/326175

Change 326188 had a related patch set uploaded (by Jforrester):
Follow-up e8dd1f43fb169: fix JS error when $wgTranslateNumerals is false

https://gerrit.wikimedia.org/r/326188

I'm deploying the fix for this now-ish (in the next 10-15 mins).

Change 326188 merged by jenkins-bot:
Follow-up e8dd1f43fb169: fix JS error when $wgTranslateNumerals is false

https://gerrit.wikimedia.org/r/326188

I'm deploying the fix for this now-ish (in the next 10-15 mins).

Thanks

Mentioned in SAL (#wikimedia-operations) [2016-12-09T22:58:19Z] <catrope@tin> Synchronized php-1.29.0-wmf.5/resources/src/mediawiki.language/mediawiki.language.numbers.js: T152800 (duration: 00m 45s)

Aklapper assigned this task to Catrope.Dec 9 2016, 11:12 PM

@Bachounda: Can you confirm that the problem is fixed now that a patch has been deployed? If yes, please feel free to set "Add Action... > Change Status > Resolved" here. Thanks!

(Thanks to Catrope for the quick fix!)

@Aklapper : All's Ok , thanks

greg closed this task as Resolved.Dec 9 2016, 11:42 PM

Change 338927 had a related patch set uploaded (by Krinkle):
mediawiki.language: Add unit tests for digit transform table

https://gerrit.wikimedia.org/r/338927

Change 338927 merged by jenkins-bot:
mediawiki.language: Add unit tests for digit transform table

https://gerrit.wikimedia.org/r/338927