Page MenuHomePhabricator

GENDER should be used for "triggered" in AbuseFilter log messages
Closed, ResolvedPublic

Description

Several messages in AbuseFilter logs should be modified such the {{GENDER}} is used for the word "triggered", as it is the user who triggers the log. Currently, {{GENDER}} is only used for "performing" (it is also the user who performed the action that triggered the log).

Example: message Abusefilter-log-entry

Currently reads:

$1: $2 triggered an abuse filter, {{GENDER:$8|performing}} the action "$3" on $4.
Actions taken: $5;
Filter description: $6

Should instead read as:

$1: $2 {{GENDER:$8}} triggered an abuse filter, {{GENDER:$8|performing}} the action "$3" on $4.
Actions taken: $5;
Filter description: $6

Similarly for Abusefilter-log-entry-withdiff and Abusefilter-log-detailedentry-meta.

While working on this, it should also be investigated why

Event Timeline

Huji created this task.Dec 10 2016, 11:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 10 2016, 11:51 PM
Huji added a comment.Dec 11 2016, 5:15 AM

Additionally, Logentry-abusefilter-hit does not use GENDER at all and should be fixed too.

Change 326371 had a related patch set uploaded (by Huji):
GENDER should be used for "triggered" in AbuseFilter log messages

https://gerrit.wikimedia.org/r/326371

Huji claimed this task.Dec 11 2016, 10:39 PM
Huji triaged this task as Low priority.

Additionally, Logentry-abusefilter-hit does not use GENDER at all and should be fixed too.

Is there a separate task for it?

Nikerabbit closed this task as Resolved.Dec 19 2016, 1:46 PM
Nikerabbit removed a project: Patch-For-Review.
Huji added a comment.Dec 19 2016, 2:57 PM

Thanks @Nikerabbit! Also, this is the second time in recent days that an i18n patch of mine has been merged and has received a -1 after being merged: https://integration.wikimedia.org/ci/job/mediawiki-extensions-qunit-jessie/19060/console

The error has something to do with timestamps (which is not something affected by the patch). The difference in expected and actual is one second, making me wonder if it is caused by the natural lag in the unit testing scripts.

Is it something to be worried about? Should I report it somwhere?

If it has to do with localised digits, Krinkle has already worked on a patch to fix that. Or this particular failure might have to do with Echo. Or there is general on-going failure caused by T153597.

Test failures should be reported and fixed, there has been many failures in tests recently, some related to code and some to the infrastructure.

Change 326371 merged by jenkins-bot:
GENDER should be used for "triggered" in AbuseFilter log messages

https://gerrit.wikimedia.org/r/326371