Page MenuHomePhabricator

Recent update to wmf/stable on Phabricator test installs: Call to undefined method PhabricatorEnv::getRemoteAddress() / PhutilIPAddress::getAddress()
Closed, ResolvedPublic

Description

Steps to reproduce

Pull phabricator, arcanist and libphutil from the wmf hosted repo's, check out wmf/stable.

Then you will get errors.

[Sun Dec 11 12:12:09.274098 2016] [:error] [pid 1422] [client 10.68.21.68:37080] >>> UNRECOVERABLE FATAL ERROR <<<\n\nCall to undefined method PhabricatorEnv::getRemoteAddress()\n\n/srv/phab/phabricator/src/applications/people/storage/PhabricatorUserLog.php:111\n\n\n\xe2\x94\xbb\xe2\x94\x81\xe2\x94\xbb \xef\xb8\xb5 \xc2\xaf\\_(\xe3\x83\x84)_/\xc2\xaf \xef\xb8\xb5 \xe2\x94\xbb\xe2\x94\x81\xe2\x94\xbb

^^ that is related to the update they are doing for supporting ipv6 I think.

Caused by https://github.com/wikimedia/phabricator/commit/6058d3305f82cec7e0d149e4d93d26706a9617e5

Event Timeline

Paladox created this task.Dec 11 2016, 12:24 PM
Restricted Application added subscribers: TerraCodes, Aklapper. · View Herald TranscriptDec 11 2016, 12:24 PM

I did this on phab-03 as someone reported T152891 and I tried to recover my account which when I tried to login gave a 500 error and I looked in the logs and got

[Sun Dec 11 12:12:09.274098 2016] [:error] [pid 1422] [client 10.68.21.68:37080] >>> UNRECOVERABLE FATAL ERROR <<<\n\nCall to undefined method PhabricatorEnv::getRemoteAddress()\n\n/srv/phab/phabricator/src/applications/people/storage/PhabricatorUserLog.php:111\n\n\n\xe2\x94\xbb\xe2\x94\x81\xe2\x94\xbb \xef\xb8\xb5 \xc2\xaf\\_(\xe3\x83\x84)_/\xc2\xaf \xef\xb8\xb5 \xe2\x94\xbb\xe2\x94\x81\xe2\x94\xbb

I think that error was just cached, I now get this error after restarting apache

[Sun Dec 11 13:59:12.216475 2016] [:error] [pid 22512] [client 10.68.21.68:35968] >>> UNRECOVERABLE FATAL ERROR <<<\n\nCall to undefined method PhutilIPAddress::getAddress()\n\n/srv/phab/phabricator/src/aphront/configuration/AphrontApplicationConfiguration.php:117\n\n\n\xe2\x94\xbb\xe2\x94\x81\xe2\x94\xbb \xef\xb8\xb5 \xc2\xaf\\_(\xe3\x83\x84)_/\xc2\xaf \xef\xb8\xb5 \xe2\x94\xbb\xe2\x94\x81\xe2\x94\xbb

Aklapper renamed this task from Recent update to wmf/stable has broke phabricator (test installs) to Recent update to wmf/stable on Phabricator test installs: Call to undefined method PhabricatorEnv::getRemoteAddress() / PhutilIPAddress::getAddress().Dec 11 2016, 2:11 PM
Paladox triaged this task as High priority.Dec 11 2016, 2:14 PM

I managed to workaround this by using some of the old code shown here https://github.com/wikimedia/phabricator/commit/6058d3305f82cec7e0d149e4d93d26706a9617e5

I also get this error when editing the differential application

Sun Dec 11 14:10:49.033737 2016] [:error] [pid 23695] [client 10.68.21.68:56882] >>> UNRECOVERABLE FATAL ERROR <<<\n\nCall to private method PhutilClassMapQuery::getCacheKey() from context &#039;PhabricatorCachedClassMapQuery&#039;\n\n/srv/phab/phabricator/src/applications/cache/PhabricatorCachedClassMapQuery.php:85\n\n\n\xe2\x94\xbb\xe2\x94\x81\xe2\x94\xbb \xef\xb8\xb5 \xc2\xaf\\_(\xe3\x83\x84)_/\xc2\xaf \xef\xb8\xb5 \xe2\x94\xbb\xe2\x94\x81\xe2\x94\xbb

That's caused by https://github.com/wikimedia/phabricator/commit/1f3fcce6fe2d5414f9bb4f1cac05caf0f78b0e0a

Setting high priority as this may break the prod install when it's deployed on Wednesday (that is if it was being planed on being updated on Wednesday)

@Paladox: I always test before deploying to prod. Thanks for catching this though.

Oh, your welcome.

mmodell closed this task as Resolved.Dec 12 2016, 8:43 AM
mmodell claimed this task.

@mmodell hi why close this as resolved?

I pushed the fix to wmf/stable.

@mmodell Hi, I just tried to git pull on phab-03 and it found no new updates and it seems to have broke because it lost my hacks as I did git reset --hard origin/wmf/stable

then

git pull