Page MenuHomePhabricator

RevisionSlider lazy loading causes arrow on bar to load on wrong side in RTL
Closed, ResolvedPublic

Description

Report at : https://www.mediawiki.org/wiki/Topic:Tgznmfaazl6ba68c

Hi. Something happened, and now the RS opening arrow is on the right side of the screen instead of usual left. When clicking, the arrow "jumps" back to the left side.

Without looking at the code I am 99% sure that this is is due to the lazy loading patch https://gerrit.wikimedia.org/r/#/c/323193/

Event Timeline

Change 326494 had a related patch set uploaded (by Addshore):
Load bar arrow on left for RTL languages

https://gerrit.wikimedia.org/r/326494

Change 326495 had a related patch set uploaded (by Addshore):
Load bar arrow on left for RTL languages

https://gerrit.wikimedia.org/r/326495

Change 326495 abandoned by Addshore:
Load bar arrow on left for RTL languages

Reason:
no longer swatting

https://gerrit.wikimedia.org/r/326495

Change 326494 merged by jenkins-bot:
Load bar arrow on left for RTL languages

https://gerrit.wikimedia.org/r/326494

Tobi_WMDE_SW moved this task from Sprint ready to Done on the WMDE-TechWish board.

Change 327475 had a related patch set uploaded (by Addshore):
Load bar arrow on left for RTL languages

https://gerrit.wikimedia.org/r/327475

Change 327475 merged by jenkins-bot:
Load bar arrow on left for RTL languages

https://gerrit.wikimedia.org/r/327475

Also backported onto the wmf6 branch now which should be deployed to everywhere this evening!