Page MenuHomePhabricator

"Proofread tools" toolbar doesn't always appear on fr.wikisource
Closed, ResolvedPublic

Description

When opening a page: https://i.imgur.com/miWFM2s.png
--> the proofread tools bar doesn't appear
After refreshing (CTRL+MAJ+R) that same page 36 times: https://i.imgur.com/ne4RH7q.png
--> the proofread tools bar finally appears.

There's probably a conflict with scripts/gadgets globally enabled on fr.wikisource because I don't have this problem on en.wikisource or wikisource.org.

It's very annoying when working on proofreading pages, this really need to be fixed, that's why i'm opening this task.

Thanks.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 12 2016, 10:07 AM
Thibaut120094 updated the task description. (Show Details)
Thibaut120094 updated the task description. (Show Details)
Thibaut120094 updated the task description. (Show Details)

Hi @Thibaut120094, thanks for taking the time to report this!

Links to test cases are welcome. :) I guess this is about
https://fr.wikisource.org/w/index.php?title=Page:Weckerlin_-_Chansons_et_rondes_enfantines,_Garnier,_1870.djvu/15&action=edit&debug=true

Cannot reproduce.
Could you please open your web browser's developer tools and reload the page on which you see the problem (and make sure that you use the URL above which has &debug=true)? If there is a problem or an error with JavaScript it should be printed in the 'console' of the developer tools. For more information please see:

Hi @Thibaut120094, thanks for taking the time to report this!

Hi! Thank you for your reply!

Links to test cases are welcome. :) I guess this is about
https://fr.wikisource.org/w/index.php?title=Page:Weckerlin_-_Chansons_et_rondes_enfantines,_Garnier,_1870.djvu/15&action=edit&debug=true

Actually it's on any page in the Page: namespace.

Cannot reproduce.

It's completely random, sometimes it appears, sometimes not.

Could you please open your web browser's developer tools and reload the page on which you see the problem (and make sure that you use the URL above which has &debug=true)? If there is a problem or an error with JavaScript it should be printed in the 'console' of the developer tools.

Tested on Firefox 50.0.2 on Windows 10 with debug=true, nothing appears in the js tab (with error and warnings enabled), however here's the console output for css.

I can get it to load without fail.

Using Firefox 50, monobook skin, and interestingly, through preferences whether I request the advanced toolbar or not, I always get the enhanced toolbar.
Whether I turn toolbar on or off, I always get the toolbar.

Loading order? Other javascript being loaded that is problematic, or delaying?

Years ago I had a somewhat similar issue that I was only seeing at meta, and inexplicable. It was resolved by uninstalling and reinstalling firefox. I never worked out why.

Thibaut120094 added a comment.EditedDec 12 2016, 11:47 AM

However, when logged off I have this output in the js console:

Gadget "stockText" styles loaded twice. Migrate to type=general. See <https://phabricator.wikimedia.org/T42284>.  index.php:1158:45

Please, load LanguageConverter from [[meta:User:He7d3r/Tools/LanguageConverter.js]].  index.php:2:1

same issue in Chrome:

Gadget "stockText" styles loaded twice. Migrate to type=general. See <https://phabricator.wikimedia.org/T42284>.
XHR finished loading: GET "https://fr.wikisource.org/w/index.php?title=MediaWiki:MediaWiki.panel.js&action=raw&ctype=text/javascript".
Please, load LanguageConverter from [[meta:User:He7d3r/Tools/LanguageConverter.js]].

Z.

Change 327027 had a related patch set uploaded (by Tpt):
Makes sure that "Proofread tools" toolbar is always loaded after Page: pages edit interface setup

https://gerrit.wikimedia.org/r/327027

Change 327027 merged by jenkins-bot:
Makes sure that "Proofread tools" toolbar is always loaded after Page: pages edit interface setup

https://gerrit.wikimedia.org/r/327027

The patch is now deployed, but unfortunately the bug is still happening.

Seb35 added a subscriber: Seb35.Jan 14 2017, 3:34 PM

Could you list what are exactly your editing preferences + gadgets, it will help to reproduce the bug. Here is a list of some parameters, which could have an influence in this bug, but add any other parameter you think it could have an influence:

  • Special:Preferences > Appearance:
    • Skin
  • Special:Preferences > Editing:
    • Enable enhanced editing toolbar
    • Enable wizards for inserting links, tables as well as the search and replace function
    • Editing mode
  • Gadgets:
    • Your enabled gadgets in the 'Editing' section + gadgets about toolbars
  • Beta features:
    • Visual editing
    • New wikitext mode

Hi @Seb35

I'm using Vector as you can see in the screenshot :)

I can reproduce the bug when I'm logged off with three different browsers (Firefox 50.1.0, Chrome 55.0.2883.87 m and Microsoft Edge 38.14393.0.0), so I don't think it comes from my gadgets or preferences.

Thibaut120094 added a comment.EditedJan 15 2017, 12:52 PM

Here's a video showing the bug in a fresh install of Ubuntu 16.10 with Firefox 50.1.0: https://goo.gl/Ky5aXw

That is a 3 minute video... Where exactly can the problem be seen?

Yeah, thanks for the video, it’s indeed quite illustrative: the section "Aide à la relecture" does not appear everytimes, it should.

Perhaps a way to fix it is to fix the gadgets triggering some error in the console, I saw there are 4-5.

Perhaps a way to fix it is to fix the gadgets triggering some error in the console, I saw there are 4-5.

Do you remember their names? Meanwhile I declared some dependencies but I doubt this was the problem back then.

Aklapper changed the task status from Open to Stalled.Jun 9 2017, 10:06 AM

Using Firefox 53 and enabling all gadgets and going to https://fr.wikisource.org/w/index.php?title=Page:Weckerlin_-_Chansons_et_rondes_enfantines,_Garnier,_1870.djvu/15&action=edit&debug=true I get the following errors:

Setting task status to stalled until those are fixed, until there are better steps to reproduce, until console output is provided when this happens.

It looks like the patch in T167317 finally fixed the problem, thank you @matmarex.

Thibaut120094 closed this task as Resolved.Jul 8 2017, 12:48 PM