Page MenuHomePhabricator

Editing a section in NWE scrolls to somewhere in the middle of the section
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Enable NWE on https://de.wikipedia.beta.wmflabs.org
  2. Go to https://de.wikipedia.beta.wmflabs.org/wiki/Benutzer_Diskussion:PerfektesChaos#Modul:DateTime
  3. Click "Quelltext bearbeiten" for that section.

Expected result: The source code is visible from start.
Actual result: While loading the editor, the page jumps up (about 1.5 screens), when the source code editor is visible, the content is scrolled up.

Just for the case this is a browser issue: Firefox 49.0.2 on Linux

Event Timeline

Schnark created this task.Dec 12 2016, 10:14 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptDec 12 2016, 10:14 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Jdforrester-WMF triaged this task as Normal priority.Dec 12 2016, 7:31 PM
Jdforrester-WMF set the point value for this task to 1.

As far as I can see this is caused by hiding the TOC when switching into edit mode. This scrolls the page up (if you are below the TOC). In visual mode the view is repositioned after loading, but not in source mode, causing the content to be scrolled up.

Change 326977 had a related patch set uploaded (by Esanders):
Don't restore scroll position when doing real section editing (NWE)

https://gerrit.wikimedia.org/r/326977

Jdforrester-WMF closed this task as Resolved.Dec 13 2016, 4:14 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF removed a project: Patch-For-Review.

Change 326977 merged by jenkins-bot:
Don't restore scroll position when doing real section editing (NWE)

https://gerrit.wikimedia.org/r/326977