Page MenuHomePhabricator

Article title containing space-colon-space can become inaccessible after a namespace is created
Closed, InvalidPublic

Description

If you create a namespace "Foo", and the wiki already has articles whose title begins with "Foo_:_", those articles become inaccessible. To reproduce:

  1. Create an article named "Foo : Bar" (with spaces around the colon) or "Foo_:_Bar" (with underscores around the colon) on a wiki that does not have a "Foo" namespace.
  2. Next, create a "Foo" namespace in LocalSettings.php: $wgExtraNamespaces[500] = 'Foo';
  3. Try to hit the original article. It is impossible. The spaces get removed, and you are redirected to "Foo:Bar" (no spaces). The original article is inaccessible.

This is on MediaWiki 1.27.1 running on Ubuntu 16.04.1 LTS. CirrusSearch version is 0.2. PHP version is:

$ php --version
PHP 7.0.8-0ubuntu0.16.04.3 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.8-0ubuntu0.16.04.3, Copyright (c) 1999-2016, by Zend Technologies
    with Xdebug v2.4.0, Copyright (c) 2002-2016, by Derick Rethans

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 12 2016, 4:08 PM
DannyS712 closed this task as Invalid.May 20 2020, 1:38 AM
DannyS712 added a subscriber: DannyS712.

Use the namespaceDupes maintenance script to fix