Page MenuHomePhabricator

Search page duplicates result
Closed, ResolvedPublic

Description

Hard to describe, easy to show:

When only 1 result is present, the same result is duplicated below the heading "Showing results from ..."

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 13 2016, 10:05 AM
dcausse triaged this task as High priority.Dec 13 2016, 12:09 PM

Damn, thanks for the report @Jdrewniak, it's probably caused by my refactoring of interwiki searches.
Will add to the backlog as it seems to be a nasty regression.

@Jdrewniak, thanks for catching this one. I'm glad this one isn't TextCat's fault!

Change 327031 had a related patch set uploaded (by DCausse):
Do not return the current wikis when detecting query languages

https://gerrit.wikimedia.org/r/327031

Change 327031 merged by jenkins-bot:
Do not return the current wikis when detecting query languages

https://gerrit.wikimedia.org/r/327031

Change 327467 had a related patch set uploaded (by DCausse):
Do not return the current wikis when detecting query languages

https://gerrit.wikimedia.org/r/327467

Deskana closed this task as Resolved.Dec 15 2016, 1:28 PM

Change 327467 merged by jenkins-bot:
Do not return the current wikis when detecting query languages

https://gerrit.wikimedia.org/r/327467

Mentioned in SAL (#wikimedia-operations) [2016-12-15T14:59:01Z] <dcausse@tin> Synchronized php-1.29.0-wmf.6/extensions/CirrusSearch: T153051: Do not return the current wikis when detecting query languages (duration: 00m 52s)