Page MenuHomePhabricator

List items are not displaying correctly on Firefox 50.0.2, Mac OS 10.9.5
Closed, DeclinedPublic

Description

Visit https://en.m.wikipedia.org/wiki/SeaMonkey and you'll see:


(notice how the bullets are not on the same line as the bullet point contents)

There is no such problem with the Vector skin:

Originally reported at https://www.mediawiki.org/wiki/Topic:Td1ru2b6a0jn2p7w

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 14 2016, 1:45 PM
bmansurov renamed this task from list items are not displaying correctly to list items are not displaying correctly on Firefox 50.0.2, Mac OS 10.9.5.Dec 14 2016, 1:46 PM
bmansurov updated the task description. (Show Details)
bmansurov renamed this task from list items are not displaying correctly on Firefox 50.0.2, Mac OS 10.9.5 to List items are not displaying correctly on Firefox 50.0.2, Mac OS 10.9.5.Dec 14 2016, 1:58 PM
bmansurov moved this task from Incoming to Triaged but Future on the Readers-Web-Backlog board.
jhobs triaged this task as Normal priority.Dec 15 2016, 5:57 PM
jhobs added a subscriber: jhobs.

Marking Normal, but please escalate to High if this turns out to be a regression.

Jdlrobson added a subscriber: Jdlrobson.

The offending css is

.content ul {
list-style: square inside;
}

Can we fixed by switching to

.content ul {
list-style: square;
}

I'm not sure if there is a good reason to do "inside" but I'm also wary that the template is making a huge assumption about how it is going to be rendered..

Jdlrobson assigned this task to Nirzar.Apr 20 2017, 11:22 PM

Is there a good reason to use square inside ?

Nirzar added a comment.EditedMay 8 2017, 4:51 PM

@Jdlrobson no reason. Let's fix this by removing inside

Nirzar added a comment.May 8 2017, 4:52 PM

@Jdlrobson actually wait... there's a reason.

Nirzar added a comment.May 8 2017, 4:54 PM

we need "inside" to keep the UL's inside the page padding. i think the problem is also having a DIV inside LI

can we do something like li > div { display:inline-block; } instead?

Nirzar lowered the priority of this task from Normal to Low.May 8 2017, 4:55 PM

I've asked on the talk page whether we can apply inline-block directly to the template:
https://en.wikipedia.org/wiki/Template_talk:Legend#display:_inline-block_for_mobile_support

TheDJ added a subscriber: TheDJ.Jun 11 2017, 1:03 PM

Not done, as that would break existing uses depending on block mode. But I note that there already was a https://en.wikipedia.org/wiki/Template:Legend_inline, so I have switched the uses of the Seamonkey article to that version.

TheDJ closed this task as Declined.Jun 11 2017, 1:04 PM
TheDJ claimed this task.
TheDJ added a subscriber: Nirzar.

Fixed by adapting the article content.