Page MenuHomePhabricator

Dash not rendering for Megan or I - probably date format related
Closed, ResolvedPublic1 Story Points

Description

Megan & I have both reported dash not working. I believe the issue started on 13-12 and affects people who think that is the right way to format a date.

The js error is
Uncaught TypeError: Cannot set property '12' of undefined(…)
scripts-08cc818a.js:111 Uncaught TypeError: Cannot set property '12' of undefined(…)

And the undefined var is the %m in e.data.xFormat="%Y-%m-%d

Here is more of the line for context. Unfortunately it is ann minified

{columns:s,groups:[t.totalGroups,t.countGroups],colors:a}):(a[t.totals[0]]="rgb(92,184,92)",a[t.counts[0]]="#f0ad4e",o[t.totals[0]]="y",o[t.counts[0]]="y2",e.data={columns:[t.xs,t.totals,t.counts],colors:a}),e.data.x="x",e.data.type="bar",e.data.xFormat="%Y-%m-%d %H",e.data.axes=o,r.xByYChart(!1),r.xByYChart(e),r.chartLoaded(!0)},r.showPanelBody=function(t){$("#"+t+"body").toggleClass("hide")},r.presetTitles=t.observableArray(["This does not work yet.","Donations During Big English 2015","Donations for Fiscal Year 2015"]),

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 14 2016, 7:23 PM
Ejegg claimed this task.Dec 19 2016, 5:14 PM
Ejegg set the point value for this task to 1.

Looks like this is actually time zone related, not date format related. I think the issue is in how we calculate the dayOfYear offset in the Campaign object. I believe this code change will fix it: https://gerrit.wikimedia.org/r/#/c/327234/1/src/app/campaign.js

Eileenmcnaughton closed this task as Resolved.Dec 19 2016, 11:08 PM

This works for me now so I'm pretty sure Megan will be OK too