Page MenuHomePhabricator

Incorrect error message shown for chunked uploads blocked by AbuseFilter
Closed, ResolvedPublic

Description

Incorrect error message is shown for chunked uploads blocked by AbuseFilter.

Internal error: Server failed to store temporary file.

Event Timeline

matmarex created this task.Dec 14 2016, 7:33 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptDec 14 2016, 7:33 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
matmarex claimed this task.Dec 14 2016, 7:36 PM
matmarex triaged this task as High priority.
matmarex added a subscriber: Anomie.

This is caused by 4e6810e4a2c1d821d8d108c7974ac16917561764. The output in this case has no machine-readable data, so we were relying on the human-readable info message, which changed because of that commit.

On the bright side, the same commit which caused the issue should allow us to do this more cleanly in the future, since the error for this is machine-readable in the new error format.

Change 327273 had a related patch set uploaded (by Bartosz Dziewoński):
mw.FormDataTransport: Update check for already completed chunked uploads

https://gerrit.wikimedia.org/r/327273

Change 327273 merged by jenkins-bot:
mw.FormDataTransport: Update check for already completed chunked uploads

https://gerrit.wikimedia.org/r/327273

I don't think this is worth back-porting?

It's difficult to tell how many users are impacted. It's a recent regression, and the patch is trivial, so I'd rather backport it.

Change 327400 had a related patch set uploaded (by Bartosz Dziewoński):
mw.FormDataTransport: Update check for already completed chunked uploads

https://gerrit.wikimedia.org/r/327400

Change 327400 merged by jenkins-bot:
mw.FormDataTransport: Update check for already completed chunked uploads

https://gerrit.wikimedia.org/r/327400

matmarex closed this task as Resolved.Dec 15 2016, 3:10 AM
matmarex removed a project: Patch-For-Review.