Page MenuHomePhabricator

[Regression] "Log in" button on log in page not in tabindex order
Closed, InvalidPublic

Description

Tab order for log in page in wmf-production (wikidata.org, mediawiki.org):

  1. User name.
  2. Password.
  3. Search field. (end of tab sequence)
  4. (start of tab list) Browser address bar
  5. (repeat)

The "Keep me logged in" checkbox and "Log in" button are not accessible through keyboard navigation.

I can consistently reproduce this in Safari 9.1.3 (latest stable), as well as in Safari Technology Preview Release 16 (Safari 10.1-alpha).

It seems this bug does not happen in latest Chrome or Firefox.

Event Timeline

Krinkle created this task.Dec 15 2016, 10:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 15 2016, 10:43 PM
Krinkle triaged this task as Unbreak Now! priority.Dec 15 2016, 10:43 PM
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptDec 15 2016, 10:43 PM
greg added a subscriber: greg.Dec 15 2016, 10:45 PM
Krinkle updated the task description. (Show Details)Dec 15 2016, 10:56 PM
Tgr added a subscriber: Tgr.Dec 15 2016, 10:59 PM

The markup seems sane:

for (i=0; i<16; i++) console.log($('[tabindex="'+i+'"]').get())
[a.uls-trigger.autonym, h3#p-variants-label, h3#p-cactions-label]
[input#wpName1.loginText.mw-ui-input]
[input#wpPassword1.loginPassword.mw-ui-input]
[input#wpRemember]
[button#wpLoginAttempt.mw-htmlform-submit.mw-ui-button.mw-ui-primary.mw-ui-progressive]
[]
[]
...

Cannot reproduce on Safari 10.0.1 (macOS Sierra).

Anomie closed this task as Invalid.Dec 16 2016, 2:29 PM
Anomie added a subscriber: Anomie.

It's a misfeature in Safari, by default it only focuses text fields when tabbing even if the tabindex attributes specify other elements. You can either use Option+Tab to tab through elements like other browser do, or go to Preferences → Advanced and check "Press Tab to highlight each item on a webpage" to make Tab work that way (and Option+Tab focus only text fields).

Also, this doesn't seem to be an actual regression, or else it's a really old one. I used wikiapiary to find some random wiki still running 1.19.0 and it exhibited the same behavior in the login form.