Page MenuHomePhabricator

OAuth API fail
Closed, ResolvedPublic

Description

Some (not all!) Wikimedia servers die with an error when performing API actions via OAuth. Instead of the requested JSON, they return a HTML error:

PHP fatal error: Call to undefined method ApiUsageException::newWithMesage()

There is an obvious typo here...?

Logstash board: https://logstash.wikimedia.org/goto/33e9ab2aaa6298692b493cc9a039d5a8

Over 24 hours:

  • ~ 2000 entries in mediawiki bucket
  • ~ 4000 entries in hhvm bucket

Details

Related Gerrit Patches:
mediawiki/extensions/OAuth : wmf/1.29.0-wmf.6Fix typo in function name
mediawiki/extensions/OAuth : masterFix typo in function name

Event Timeline

Magnus created this task.Dec 16 2016, 9:20 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 16 2016, 9:20 AM
Magnus triaged this task as Unbreak Now! priority.Dec 16 2016, 9:20 AM
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptDec 16 2016, 9:20 AM

Addendum: Observed on wikidata, with [action] => query, [meta] => userinfo; probably affects other API calls as well. Again, some servers seem to work, others don't.

Change 327713 had a related patch set uploaded (by Alex Monk):
Fix typo in function name

https://gerrit.wikimedia.org/r/327713

hashar updated the task description. (Show Details)

@Magnus, can you provide a script to reproduce the issue?

Change 327713 merged by jenkins-bot:
Fix typo in function name

https://gerrit.wikimedia.org/r/327713

Change 327714 had a related patch set uploaded (by Alex Monk):
Fix typo in function name

https://gerrit.wikimedia.org/r/327714

Magnus added a comment.EditedDec 16 2016, 10:34 AM

This works sometimes, but not others:
https://tools.wmflabs.org/widar/?test=1
If you see some chrome and JSON, it's fine, otherwise, WMF error messages.

Still broken for me

Change 327714 merged by jenkins-bot:
Fix typo in function name

https://gerrit.wikimedia.org/r/327714

Krenair closed this task as Resolved.Dec 16 2016, 10:42 AM
Krenair claimed this task.

Thanks @Magnus, that link was useful.

Works for me now, thanks!

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:10 PM