Page MenuHomePhabricator

"Older 500" link in Commons' "Gallery of new files" produces only 50 results (but not when logged out)
Open, Needs TriagePublic

Description

Steps to reproduce:

  1. Go to https://commons.wikimedia.org/w/index.php?title=Special:NewFiles&offset=&limit=500
  2. Click "older 500" link at foot of page

Actual results:
50 older results are displayed

Expected results:
500 older results should be displayed

The URL for the link "older 500" is, e.g., https://commons.wikimedia.org/w/index.php?title=Special:NewFiles&offset=20161216105509 , whereas it should be https://commons.wikimedia.org/w/index.php?title=Special:NewFiles&offset=20161216105509&limit=500

Event Timeline

Rrburke created this task.Dec 16 2016, 11:22 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 16 2016, 11:22 AM

@Rrburke It seems to still display 500 files using "older 500". And the link also contains "&limit=500". What OS and browser do you use? FYI, I am using Google Chrome on Windows XP SP3.

@Pokefan95 I'm using Google Chrome and Windows 10. I just tried loading the page while logged out and found that "&limit=500" was present. It must be something in my preferences.

@Rrburke: Cannot reproduce either...
Does this also happen when adding like the safemode=1 parameter to the URL, like https://commons.wikimedia.org/w/index.php?title=Special:NewFiles&offset=&limit=500&safemode=1 ?
Does this also happen after disabling gadgets on https://commons.wikimedia.org/wiki/Special:Preferences#mw-prefsection-gadgets ?

Aklapper renamed this task from "Older 500" link in Commons' "Gallery of new files" produces only 50 results to "Older 500" link in Commons' "Gallery of new files" produces only 50 results (but not when logged out).Apr 20 2017, 4:28 PM

@Rrburke: Could you answer the last questions please?

@Aklapper: Sorry for the tardy reply. Yes, it still happens when safemode=1 is set. I tried disabling all gadgets, but the problem persists.