Add new page protection level on et.wikipedia.org
Closed, ResolvedPublic

Description

New user group (Autopatrolled) was added to et.wikipedia.org recently (see T150852). We are requesting for a new page protection level that goes with the group (see community discussion).

Right now there are three page protection levels on etwiki:
protect-default
protect-level-autoconfirmed
protect-level-sysop

The new protection level would allow restricting page editing and moving to sysops and members of Autopatrolled group. The level would be between levels 'protect-level-autoconfirmed' and 'protect-level-sysop'. I think that the name of the new protection level should be e.g. 'protect-level-autopatrolled' (but I'm not familiar with the naming policy, so it could be something else). It would be great if adding sysops to Autopatrolled group wasn't necessary for the new protection level to work.

Cumbril created this task.Dec 16 2016, 3:44 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 16 2016, 3:44 PM
Cumbril edited the task description. (Show Details)Dec 16 2016, 4:05 PM

Setting project to Wikimedia-Site-requests, as this request is about settings / configuration of a Wikimedia website.

For more information about how to request these kinds of changes, please see https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes

Urbanecm claimed this task.Dec 16 2016, 6:01 PM
Urbanecm added a subscriber: Urbanecm.

Will do this. But as this is non-emergency thing it'll be deployed after New Year Day.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptDec 16 2016, 6:01 PM
Urbanecm triaged this task as "Low" priority.Dec 16 2016, 6:01 PM
Urbanecm moved this task from Backlog to Working on on the User-Urbanecm board.
Urbanecm moved this task from Backlog to Working on on the Wikimedia-Site-requests board.
Urbanecm added a comment.EditedDec 16 2016, 7:58 PM

Basically any protection level is based on right (not on group). So as sysops have autopatrol right by default they don't need to be added to the autopatrolled group. Can you tell how it should be in the protection dialog in Estonian? What words should appear there? Or, as you have translator rights at translatewiki.net, you can translate it yourself using https://translatewiki.net/wiki/MediaWiki:Protect-level-autopatrol/et.

Change 327789 had a related patch set uploaded (by Urbanecm):
Add new page protection level on etwiki

https://gerrit.wikimedia.org/r/327789

Urbanecm moved this task from Working on to To deploy on the User-Urbanecm board.

Will be deployed at January 3rd 14:00-15:00 UTC. Sorry for the delay, until this date there won't be any non-emergency deploys due to the end of year. This is the first possible window.

Cumbril added a comment.EditedDec 16 2016, 9:07 PM

Created translation at translatewiki.net (https://translatewiki.net/wiki/MediaWiki:Protect-level-autopatrol/et).

This is the line that should appear in the page protection dialogue window, where one can select protection level.

Pikne added a subscriber: Pikne.Dec 16 2016, 9:45 PM

... as you have translator rights at translatewiki.net, you can translate it yourself using https://translatewiki.net/wiki/MediaWiki:Protect-level-autopatrol/et.

It's not defined as a message in any message group (or i18n file) and hence cannot be translated via translatewiki.net. Text for this message needs to be provided locally.

Really? It's defined in mediawiki/extensions/WikimediaMessages and this extension take translations from translatewiki.net.

Pikne added a comment.Dec 17 2016, 8:41 AM

Really? It's defined in mediawiki/extensions/WikimediaMessages and this extension take translations from translatewiki.net.

I don't find it in WikimediaMessages. There are messages for some other custom protection levels that Wikimedia uses even more rarely than this level though. So another option probably is to add this message too in WikimediaMessages, along with "restriction-level-autopatrol" which would appear in lists of protected pages and titles.

Okay. I'll add it there manually. @Cumbril: Can you tell how should be the protection level called in special:protectedtitles and special:protectedpages?

Change 327908 had a related patch set uploaded (by Urbanecm):
Add Protect-level-autopatrol in et.json

https://gerrit.wikimedia.org/r/327908

Why I modified your patch: messages need to be defined in source (en.json) to be picked up for translation via translatewiki.net. Translations for specific languages can be committed directly to repo, but it's not necessary. Current Estonian translation is not ok as it doesn't follow the English source because the autopatrollers group name itself is custom (i.e. not following the English source) on Estonian Wikipedia. So these texts using custom group name still need to be provided locally as well.

Urbanecm added a comment.EditedDec 17 2016, 10:32 AM

@Pikne Thanks for the modification. I modified it because you stole my patch :D. Commit message said it were you who originaly created it but gerrit it was me. Just for clarify. If the patch will be merged right now (PS5 is current newest version), the translation will be inserted by translatewiki bot in few of days? If so I think the patch is ready for be merged and the rest will be done by the bot.

Yes, this should be how it works.

This stealing part was due to my poor gerrit skills. Sorry about that. :)

Urbanecm added a comment.EditedDec 17 2016, 10:55 AM

Nothing happened, this is easy to fix :). Thanks for your fix and advice. So @Cumbril, please translate "autopatroller protected" at https://translatewiki.net/wiki/MediaWiki:Restriction-level-autopatrol/et. The rest will be done by bot.

Cumbril added a comment.EditedDec 17 2016, 1:32 PM

@Urbanecm
Created the translation in translatewiki.net. Now there are Translatewiki translations both for "protect-level-autopatrol" and "restriction-level-autopatrol" system messages. Since etwiki uses custom name for Autopatrollers as Pikne noted, Translatewiki translations can be made to be in correspondence with their literal meanings and I will add custom translations in etwiki.

Okay, create please both of them locally :).

Change 327789 merged by jenkins-bot:
Add new page protection level on etwiki

https://gerrit.wikimedia.org/r/327789

Mentioned in SAL (#wikimedia-operations) [2017-01-03T14:08:36Z] <hashar@tin> Synchronized wmf-config/InitialiseSettings.php: Add new page protection level on etwiki - T153465 (duration: 00m 53s)

Urbanecm closed this task as "Resolved".EditedJan 3 2017, 2:13 PM

Deployed. If doesn't work please reopen.