Page MenuHomePhabricator

Receiving spam from @toolserver.org address
Closed, ResolvedPublic

Description

I keep receiving tons of spam emails (one every few minutes) to my old pietrodn@toolserver.org email that redirects to my personal email address.

I can't disable the email forwarding because the Toolserver has been dismissed.

I don't need the Toolserver address anymore. Is there any possibility to disable that address permanently?

Event Timeline

Pietrodn created this task.Dec 16 2016, 4:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 16 2016, 4:21 PM

Looks like this domain's mail is handled by the toolserver-legacy labs project. We don't seem to have a matching phabricator project so I'm CCing the projectadmins instead.

Restricted Application added a project: Cloud-Services. · View Herald TranscriptDec 16 2016, 6:45 PM
Dzahn removed a subscriber: Dzahn.Dec 16 2016, 6:51 PM
Dzahn added a subscriber: Dzahn.Dec 16 2016, 6:57 PM
Dzahn added a comment.Dec 16 2016, 7:04 PM

So this was once setup by @coren. I found in puppet repo puppet/modules/toolserver_legacy/templates/exim4.conf.erb which has:

..
begin routers

# Redirect using the alias file if it exists, blackhole otherwise

system_aliases:
        driver = redirect
        domains = @
        data = ${lookup{$local_part}lsearch{/etc/toolserver.aliases}{$value}{:blackhole:}}
        qualify_domain = wmflabs.org
..

From there i saw the /etc/toolserver.aliases part (really this should be in /etc/exim4/aliases/ where i looked at first). (this file does not look puppetized, but should be)

From wikitech web ui i could see the instance this runs on is relic.toolserver-legacy.eqiad.wmflabs and in the toolserver.aliases there i see your pietrodn alias, and i just deleted it. Then ran puppet to confirm it's not generated and it wasn't.

The spam should have stopped now.

Dzahn closed this task as Resolved.Dec 16 2016, 7:05 PM
Dzahn claimed this task.

please reopen if it hasn't stopped

Mentioned in SAL (#wikimedia-labs) [2016-12-16T19:06:55Z] <mutante> removed toolserver mail alias by request (T153471)

Thank you. The spam has stopped. :)