Page MenuHomePhabricator

Can't open VisualEditor with &uselang=qqx
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Click https://en.wikipedia.org/w/index.php?title=User:Whatamidoing_(WMF)/sandbox&veaction=edit&uselang=qqx
  2. Did VisualEditor open for you?
  3. Me neither.
  4. Be sad.
  5. Pester someone to find out what that string's name is.

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptDec 16 2016, 4:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Need to add uselang/useskin to the whitelist of params we don't freak out about? (I could have sworn this used to work.)

Jdforrester-WMF triaged this task as Normal priority.Dec 16 2016, 4:50 PM
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

It worked a week or two ago in visual mode, but I haven't tried it since enabling the Beta Feature for the 2017 wikitext editor.

Need to add uselang/useskin to the whitelist of params we don't freak out about?

I don't think we have one. We do have a list of parameters to freak out about, but uselang is not among them.

This is in console:
Uncaught Error: Incomplete trigger
ve.ui.TriggerRegistry.register @ ve.ui.TriggerRegistry.js?c7b3f:59
(anonymous function) @ ve.ui.MWSaveDialogAction.js?81b5a:94
(anonymous function) @ ve.ui.MWSaveDialogAction.js?81b5a:103

Change 327892 had a related patch set uploaded (by Alex Monk):
Don't break everything if we end up with strange accesskey messages

https://gerrit.wikimedia.org/r/327892

matmarex renamed this task from Can't open VisualEditor with &uselang=xx to Can't open VisualEditor with &uselang=qqx.Jan 3 2017, 7:41 PM
matmarex added a subscriber: Amire80.

Change 327892 merged by jenkins-bot:
MWSaveDialogAction: Don't break on strange accesskey messages

https://gerrit.wikimedia.org/r/327892

Jdforrester-WMF closed this task as Resolved.Jan 3 2017, 7:54 PM
Jdforrester-WMF set the point value for this task to 1.