Page MenuHomePhabricator

&section=new results in an un-editable default edit summary
Closed, DeclinedPublic

Description

Steps to reproduce:

  1. Add a new section to a talk page, e.g., https://en.wikipedia.org/wiki/User_talk:Whatamidoing_(WMF)?veaction=editsource&section=new
  2. Add a section title and some content
  3. Click the Save button
  4. See the default edit summary of /* Subject */ new section pre-filled (very nice)
  5. Realize that it's grayed out and you can't change it.

Ideal behavior: Having the very nice default edit summary, but being able to change it, too.

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptDec 19 2016, 4:43 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

It looks like this gets disabled whenever VE decides what the Subject part is going to be, presumably so the user can't change it? Can you shed some light on this behaviour @Esanders?

This is the same behaviour as the old editor, except in the old editor we just hide the summary. With VE we have a principle of keeping the UI consistent, so disabling is more appropriate.

Can we hide it in VisualEditor, then? When I see it, I want to be able to change it.

We could, but I refer you to my previous comment.

Elitre added a subscriber: Elitre.Jan 3 2017, 5:22 PM
Jdforrester-WMF closed this task as Declined.Jan 4 2017, 1:22 AM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

In general, we don't hide things in some modes, we disable them instead.