Page MenuHomePhabricator

MSSQL Database error from SqlBagOStuff after upgrading to 1.28.0
Open, Needs TriagePublic

Description

MSSQL: Database error after upgrading to 1.28.0

I have MediaWiki 1.27.1 installed:
MediaWiki 1.27.1
PHP 5.6.20 (cgi-fcgi)
MS SQL Server 11.00.2100
Windows 7 Enterprise, Servicepack 1, 64 Bit

I upgraded to MediaWiki 1.28.0. For the database upgrade I used the web installation. The upgrade process was successful. When I start the wiki I get database errors. The query

SELECT  keyname,value,exptime  FROM [CI_objectcache]    WHERE keyname = 'cT_Dev_Wiki-CI_:MWSession:12qarj4g76hh1r08ohf3ikivsj9cjeo9'

fails. The object “CI_objectcache” is unknown. The table “CI_objectcache” exists in the database. If I run the statement in the SQL Server Management Studio I get the same error. If I put the schema name in front of the table name the query

SELECT  keyname,value,exptime  FROM [wiki].[CI_objectcache]    WHERE keyname = 'cT_Dev_Wiki-CI_:MWSession:12qarj4g76hh1r08ohf3ikivsj9cjeo9'

works.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 21 2016, 4:23 PM

Adding @aaron since it seems that the fixes we did to postgres need to be applied to mssqlplease.

Krinkle renamed this task from MSSQL: Database error after upgrading to 1.28.0 to MSSQL Database error from SqlBagOStuff after upgrading to 1.28.0.Jul 18 2019, 2:45 PM
Krinkle edited projects, added MediaWiki-Cache; removed MediaWiki-Rdbms.
Krinkle moved this task from Backlog to libs/objectcache on the MediaWiki-Cache board.