Page MenuHomePhabricator

decom europium (was: reclaim europium)
Closed, ResolvedPublic

Description

created as a subtask of T82239

server europium was gone from puppet and DNS but not fully decomed. OS was still installed and it was booting up when i connected to mgmt.

but in 2013 there was a comment from Asher that it can be reclaimed

i used it for installserver tests and reinstalled jessie, now it can really be reclaimed, go to spares or be used for something else

HW warranty expiration: 2015-08-29

WMF4084


This checklist is able to be copied and pasted into phabricator hardware request tasks for reclaiming systems to spare or decom.

  • - all system services confirmed offline from production use
  • - set all icinga checks to maint mode/disabled while reclaim/decommmission takes place.
  • - remove system from all lvs/pybal active configuration
  • - any service group puppet/hiera/dsh config removed
  • - remove site.pp (replace with role::spare if system isn't shut down immediately during this process.)

START NON-INTERRUPPTABLE STEPS

  • - disable puppet on host
  • - remove all remaining puppet references (include role::spare)
  • - power down host
  • - disable switch port
  • - switch port assignment noted on this task (for later removal)
  • - remove production dns entries
  • - puppet node clean, puppet node deactivate, salt key removed

END NON-INTERRUPPTABLE STEPS

  • - system disks wiped (by onsite)
  • - IF DECOM: system unracked and decommissioned (by onsite), update racktables with result
  • - IF DECOM: switch port configration removed from switch once system is unracked.
  • - IF DECOM: mgmt dns entries removed.
  • - IF RECLAIM: system added back to spares tracking (by onsite)

Details

Related Gerrit Patches:
operations/puppet : productionClean up netboot config
operations/dns : masterdecom europium, keep mgmt
operations/puppet : productionDHCP: decom europium

Event Timeline

Restricted Application added a subscriber: Southparkfan. · View Herald TranscriptDec 21 2016, 11:36 PM

europium.eqiad.wmnet - eqiad row C - C7 @ 38

Mentioned in SAL (#wikimedia-operations) [2016-12-21T23:48:04Z] <mutante> europium - jessie reinstall done - powered down until until reclaim (T153918)

Dzahn removed RobH as the assignee of this task.Dec 21 2016, 11:49 PM
Dzahn added a subscriber: Cmjohnson.
Cmjohnson moved this task from Backlog to Not urgent on the ops-eqiad board.Apr 27 2017, 8:40 PM
Dzahn claimed this task.May 3 2017, 4:31 PM

Change 351587 had a related patch set uploaded (by Dzahn; owner: Muehlenhoff):
[operations/puppet@production] Clean up netboot config

https://gerrit.wikimedia.org/r/351587

Dzahn renamed this task from reclaim europium to decom europium (was: reclaim europium).May 3 2017, 4:51 PM
Dzahn updated the task description. (Show Details)

Change 351676 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] DHCP: decom europium

https://gerrit.wikimedia.org/r/351676

Dzahn updated the task description. (Show Details)May 3 2017, 4:56 PM

Change 351677 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/dns@master] decom europium, keep mgmt

https://gerrit.wikimedia.org/r/351677

Change 351587 merged by Dzahn:
[operations/puppet@production] Clean up netboot config

https://gerrit.wikimedia.org/r/351587

Change 351676 merged by Dzahn:
[operations/puppet@production] DHCP: decom europium

https://gerrit.wikimedia.org/r/351676

Change 351677 merged by Dzahn:
[operations/dns@master] decom europium, keep mgmt

https://gerrit.wikimedia.org/r/351677

Dzahn updated the task description. (Show Details)May 3 2017, 6:08 PM

revoked puppet cert, removed prod IP, was already shut down since a while, checked all the boxes i could do. handing over for switch config and datacenter-ops steps.

Dzahn reassigned this task from Dzahn to Cmjohnson.May 3 2017, 6:10 PM
Dzahn removed Cmjohnson as the assignee of this task.
Dzahn removed a project: Patch-For-Review.
Dzahn added a subscriber: ayounsi.

@RobH see above, wanna check for switch port? thanks

Cmjohnson moved this task from Not urgent to Up next on the ops-eqiad board.May 4 2017, 6:15 PM
Cmjohnson closed this task as Resolved.May 9 2017, 3:28 PM
Cmjohnson claimed this task.

updated racktables