Page MenuHomePhabricator

Allow non-CC0 licensed data for datasets
Closed, ResolvedPublic

Tokens
"100" token, awarded by Richard_Nevell_WMUK."Mountain of Wealth" token, awarded by Mrjohncummings."Love" token, awarded by Liuxinyu970226."Like" token, awarded by Offnfopt."Love" token, awarded by Raymond.
Assigned To
Authored By
Yurik, Dec 24 2016

Description

This task is about legal aspects only. For technical implementation, see T200968 and T155290 instead.

Per community discussion, we need to figure out the licensing options for the Commons Datasets. A good example is UNData terms of use:

All data and metadata provided on UNdata’s website are available free of charge and may be copied freely, duplicated and further distributed provided that UNdata is cited as the reference.

Does this imply that the data is CC0 because we can copy it, mark it as CC0, but since we are providing a link to the source, we are ok? Also, it does not say that the derivative works (e.g. a visualization of that data like a graph) needs to cite the source (although it could of course). I suspect that this is different, but since its not one of the well defined licenses, e.g. CC-BY, and simply because it's a legal matter, I would like legal to comment how we should proceed with this?

Requested licenses:

  • CC-BY
  • ODbL

...?

There is also another discussion about using more restrictive licensing here.

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 24 2016, 4:01 AM

Because it imposes requirements on users beyond CC0 (e.g. citing UNdata) we'd be wrong to call it CC0, and someone who relied on our declaration of CC0 could get into trouble.

You'll want to get legal's comments, but it's not clear to me that their license is even open since it's silent on modifying what they provide as well as derivative works.

debt removed Slaporte as the assignee of this task.
debt renamed this task from Support more licenses for Datasets to Investigate viability of using licensed databases (other than CC0).
debt added subscribers: MaxSem, kaldari.

Added a meeting to chat about this with Legal and the Interactive team on Thursday, Jan 5, 2017

Yurik updated the task description. (Show Details)Jan 5 2017, 5:09 AM
debt updated the task description. (Show Details)Jan 5 2017, 7:55 PM
Yurik renamed this task from Investigate viability of using licensed databases (other than CC0) to Allow non-CC0 licensed data for datasets.Jan 11 2017, 5:59 PM

CC BY 3.0 (at least) is needed for using Open Data from Cologne: https://offenedaten-koeln.de/

Another Opene Date license worth to add is Data licence Germany – attribution – version 2.0. AFAIK fully compatible to CC BY. Wikimedia Commons has already a license template for it: https://commons.wikimedia.org/wiki/Template:Data_license_Germany-attribution-2.0

Added a meeting to chat about this with Legal and the Interactive team on Thursday, Jan 5, 2017

Could you post the results/minutes from the meeting?

debt added a comment.Jan 18 2017, 2:35 PM

Hi @Legoktm - we chatted about this with @Slaporte on Jan 5 and he said he would do some research into this but he also felt that it would be a pretty huge undertaking to get this done, from a legal standpoint. The team was going to prioritize this request along with the other work that needs to be done and once we received the info from Stephen, we'd then make the decision to do the work or not. I don't believe minutes were taken during the meeting.

@debt Short note from a German user perspective: Not allowing CC BY and similar licences would be a huge loss of possible use cases of already published open data at least in Germany.

Deskana closed this task as Declined.Jan 23 2017, 8:45 PM
Deskana added a subscriber: Deskana.

Given that we're still working on a first release of a multitude of features, sadly this task cannot be prioritised right now.

Legoktm reopened this task as Open.Jan 23 2017, 8:49 PM
Legoktm lowered the priority of this task from Normal to Lowest.

Given that we're still working on a first release of a multitude of features, sadly this task cannot be prioritised right now.

I changed the priority field then - it's still a legitimate bug.

Any news on this topic? Can we use CC-BY?

debt added a comment.Oct 15 2017, 1:37 PM

@Sabas88, there has been no movement on this issue, unfortunately.

There is another conversation going on a related ticket — T155290 — that deals with another issue of using wikimarkup to determine licensing and data attribution. We might be able to get resolution on that ticket/issue that might help with this issue.

Offnfopt added a subscriber: Offnfopt.
RP88 added a subscriber: RP88.Oct 16 2017, 10:45 PM
Fae added a subscriber: Fae.Oct 18 2017, 8:32 PM
debt added a comment.Nov 7 2017, 1:50 AM

Please read the posting here: T178210#3734520 for further information.

Ayack added a subscriber: Ayack.May 7 2018, 5:42 PM

I spoke with @Doc_James at the Wikimedia Conference this spring, and he asked me to clarify the requirements for non-CC0 content in tabular data.

Wikimedia is allowed to host data that is released under a free license (following the Licensing Policy), but there are a few additional features necessary to support non-CC0 licenses:

  1. Save dialogue needs to display the correct license: When editing tabular data, the page currently says: "By saving changes, you agree to the Terms of Use, and you irrevocably agree to release your contribution to the public domain under CC0." There is also a box above the edit box. The interface should say that contributions are released under the specified license. (See an example here)
  1. Data page must display the correct license: When viewing tabular data, the bottom of the page currently says: "Data available under Creative Commons Zero." Instead, this should display the correct information based on the license key in the data.

The Wikimedia Foundation Reading Infrastructure team is not planning active development on Tabular Data (JsonConfig), but will be available to conduct code review of volunteer patches for this effort. Additionally, if changes are made, there should be an update to the Tabular Data documentation.

Any templates that pull data from non-CC0 licensed datasets will need to comply with the relevant attribution terms. As @Yurik explained in T178210#3734569, it is sufficient this is handled in templates.

Thanks Stephen

debt closed this task as Resolved.Jul 9 2018, 7:55 PM
debt claimed this task.

Thanks for the info, @Slaporte ! Closing this ticket as resolved for the information that has been given.

MartinK added a subscriber: MartinK.Aug 2 2018, 5:36 AM

Hi all

I'm working on a how to page for uploading map data to Commons and linking it and using it one Wikidata (will probably get split up a bit in the end to Commons as well).

https://www.wikidata.org/wiki/User:John_Cummings/Map_data

Should I wait until this task is resolved before publishing? I'm not sure if its allowed to upload non CC0 license data yet to Commons

Thanks

Mrjohncummings rescinded a token.
Mrjohncummings awarded a token.
Mrjohncummings rescinded a token.
Mrjohncummings awarded a token.

Question, should this also include CC BY-SA, ODbL and 'does not meet the threshold for originality' since it is bringing it in line with Commons licensing? This would mean that we could import OSM shapes which would be very nice

@eranroz were are we at with this? Are we supported to use none CC-0 licenses on Commons yet?

The current situation is confusing

https://www.mediawiki.org/wiki/Help:Map_Data?rdfrom=commons:Help:Map_Data states all Commons compatible licenses are accepted

Then when creating a page on Commons it says CC0 only

Yes the issue is that we need a patch to allow other licenses to be listed.

J

As Deb mentioned in 2017 see: T155290

Sorry, why is this task marked as resolved? Ir doesn't seem resolved

To clarify: this task is a legal task.
it is solved thanks to the informative answer of @Slaporte in T154071#4323571

As for technical solution there are 2 approaches:

(I'll comment with additional info in the correct task to avoid out of topic here :) )

Aklapper updated the task description. (Show Details)Jan 23 2019, 9:54 AM
Nikki added a subscriber: Nikki.Mon, Jun 24, 11:21 AM

Will we also be allowed to upload data which uses CC BY 3.0 DE and the Datenlizenz Deutschland licenses? German cities often use one of those for their open data, but I don't see them listed on https://www.mediawiki.org/wiki/Help:Map_Data

I do not see why not.

Mrjohncummings added a comment.EditedTue, Jun 25, 12:10 PM

Will we also be allowed to upload data which uses CC BY 3.0 DE and the Datenlizenz Deutschland licenses? German cities often use one of those for their open data, but I don't see them listed on https://www.mediawiki.org/wiki/Help:Map_Data

I think the list of licenses which this supports should be the same list of licenses as Commons since it is being hosted on Commons?

Is this correct?

If yes I think this should provide a full list if you add the lists up together? https://commons.wikimedia.org/wiki/Commons:Copyright_tags

If yes then we should make a long list and add it to the task description