Page MenuHomePhabricator

Upload Wizard: Remember uploader name
Closed, ResolvedPublic

Description

It would be great if the Upload Wizard could remember the name of the uploader:

I have to replace my username with my real name, every time I upload. Not a huge hassle, but a small quality of life improvement. Something simple like storing the name in a cookie would do.

Event Timeline

Srittau created this task.Dec 26 2016, 6:02 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptDec 26 2016, 6:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Jarekt added a subscriber: Jarekt.Dec 27 2016, 6:18 PM

Yes please, allow to set a preferred uploader name, or remember the username form from the last upload

matmarex added a subscriber: matmarex.

It could just be a user preference. We already let you select the default license there.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptJan 19 2017, 12:33 PM

Change 334877 had a related patch set uploaded (by Pmlineditor):
Add user preference to allow setting a default uploader name

https://gerrit.wikimedia.org/r/334877

Raymond added a subscriber: Raymond.Jun 9 2017, 7:17 PM

Kind of dupe of T40026?

Jarekt added a comment.Jun 9 2017, 7:20 PM

T40026 sounds to me like expanded version of this task.

Blahma added a subscriber: Blahma.Jun 11 2017, 11:32 AM

Change 334877 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Add user preference to allow setting a default uploader name

https://gerrit.wikimedia.org/r/334877

Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.Nov 18 2017, 12:52 AM
Ramsey-WMF triaged this task as Normal priority.Nov 20 2017, 6:35 PM
matthiasmullie closed this task as Resolved.Nov 21 2017, 3:49 PM
Johan added a subscriber: Johan.Nov 24 2017, 3:57 PM

Will this be fully in production and working from wmf.10?