Page MenuHomePhabricator

JSON 1.8 is not compatible with Ruby 2.4
Closed, ResolvedPublic

Description

Ruby 2.4 is released and JSON 1.8 is not compatible. JSON 2.0 works fine with Ruby 2.4.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 28 2016, 11:30 AM

Change 329450 had a related patch set uploaded (by Zfilipin):
Update JSON gem to version 2

https://gerrit.wikimedia.org/r/329450

zeljkofilipin triaged this task as Low priority.Dec 28 2016, 11:41 AM
zeljkofilipin moved this task from Inbox to In Progress on the Browser-Tests-Infrastructure board.

Change 329450 merged by jenkins-bot:
Update JSON gem to version 2

https://gerrit.wikimedia.org/r/329450

Change 329451 had a related patch set uploaded (by Zfilipin):
Release patch version 1.7.4

https://gerrit.wikimedia.org/r/329451

Change 329451 merged by jenkins-bot:
Release patch version 1.7.4

https://gerrit.wikimedia.org/r/329451

Change 329454 had a related patch set uploaded (by Zfilipin):
Updated mediawiki_selenium Ruby gem

https://gerrit.wikimedia.org/r/329454

Change 329454 merged by jenkins-bot:
Updated mediawiki_selenium Ruby gem

https://gerrit.wikimedia.org/r/329454

zeljkofilipin closed this task as Resolved.Jan 7 2017, 11:58 AM