Page MenuHomePhabricator

Bizzare behavior when newsletter moved outside Newsletter namespace
Closed, ResolvedPublic

Description

It is possible to move a newsletter out of the newsletter namespace, which then causes all of the links to the newsletter in the newsletter Special pages to be red. If one tries to change the title of a newsletter, either in the same cross-namespace move or later, an error of "Cannot find newsletter with name <NEW NEWSLETTER NAME>" appears.

Details

Related Gerrit Patches:

Related Objects

StatusSubtypeAssignedTask
DuplicateQgil
ResolvedQgil
ResolvedQgil
DeclinedNone
ResolvedAddshore
DuplicateNone
Resolvedori
ResolvedBawolff
ResolvedGlaisher
ResolvedTinaj1234
DeclinedNone
ResolvedGlaisher
Resolved01tonythomas
ResolvedGlaisher
Resolved01tonythomas
OpenNone
OpenDaimona
OpenDaimona
Resolved01tonythomas
ResolvedQgil
ResolvedFilip
ResolvedD3r1ck01
ResolvedNone
Resolved01tonythomas
Resolved01tonythomas
Resolved01tonythomas
Resolved01tonythomas
ResolvedPppery

Event Timeline

Pppery created this task.Dec 31 2016, 8:23 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 31 2016, 8:23 PM

Is it being thrown up as an Exception, or as a fatal error (like white screen with this line) ?

Pppery added a comment.EditedDec 31 2016, 9:58 PM

An MWException; the main background with navigation links and such still appears, and a stack trace is shown.

An MWException; the main background with navigation links and such still appears, and a stack trace is shown.

Well, in that case it wont be an issue, I guess - as currently the right to move around something in Newsletter namespace is reserved for 'Administrators', and we cannot expect them to do things lik this!

Except that it seems to only require Autoconfirmed rights to move a newsletter (?)

Except that it seems to only require Autoconfirmed rights to move a newsletter (?)

Hmm. That sounds strange. Can you confirm this with probably a new account (and in that case, please report)

The ? in the above comment meant "How odd", not "Maybe; unconfirmed"; I had already tested this before saying it.

in T154379#2909079, @Pppery wrote:
Except that it seems to only require Autoconfirmed rights to move a newsletter (?)

The ? in the above comment meant "How odd", not "Maybe; unconfirmed"; I had already tested this before saying it.

Well. I got confsued with your use of 'seems'. Anyway, nice find and I can reproduce this.

Filip added a subscriber: Filip.Jan 1 2017, 3:16 PM

@Pppery: @01tonythomas Cant reproduce error, when I move this to the another namespace, all description data/ after clicking edit button are lost. But no errors are thrown. Tried on fresh git clone. Maybe there's function to pass namespace to move form.

Pppery added a comment.Jan 1 2017, 4:28 PM

Well, in any case, my patch for T154380 seems to have fixed this as a side effect

Change 329815 had a related patch set uploaded (by Pppery):
Introduce stricter validation involving Newsletters' content models

https://gerrit.wikimedia.org/r/329815

Change 329815 merged by jenkins-bot:
Introduce stricter validation involving Newsletters' content models

https://gerrit.wikimedia.org/r/329815

01tonythomas closed this task as Resolved.Jan 3 2017, 9:03 PM
01tonythomas assigned this task to Pppery.
Qgil awarded a token.Jan 7 2017, 10:36 AM