Page MenuHomePhabricator

Tabs collapsed on LTR wikis for RTL users
Closed, ResolvedPublic

Description

Bug description:

In any LTR wiki, when viewing a page while setting an RTL language (ar, fa, he, etc) in your preferences, all tabs are collapsed which makes it difficult to edit any page (press on edit tab).

For illustration of bug please see URL.

Note that there is a gadget on Meta that fixes this

http://meta.wikimedia.org/wiki/MediaWiki:Gadget-rtl.css


Version: unspecified
Severity: enhancement
URL: http://meta.wikimedia.org/w/index.php?title=Main_Page&uselang=ar

Details

Reference
bz13447

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:06 PM
bzimport set Reference to bz13447.
Meno25 created this task.Mar 20 2008, 9:50 AM
Huji added a comment.Mar 21 2008, 11:13 AM

I'm afraid this can't be taken care of, with our current approach about the directional style sheets: We only call RTL styles when the "content" of the wiki is in an RTL language. This means, pieces of CSS that make the preferences page look correct in RTL-contented wikis, won't be called and used on LTR-contented ones, disregarding the uselang parameter.

  • This bug has been marked as a duplicate of bug 6100 ***

Removing duplicate to bug 6100, adding dependancy to bug 6100.

This should be taken in to account after fixing bug 6100, to verify that it's fixed.

I don't see the bug on MetaWiki (which at this moment still uses MW 1.17, which is before the RTL improvements). It's probably fixed, but it would be good if someone else confirms it as well.

Amir, can you please test this?

I'm not sure what the bug was, and so i am not sure what i should test.

I would guess that it's solved, because the RTL gadget mentioned in the description was deleted and because 1.18 changed so many things in this regard.

Meno25, can you please verify this?

Huji added a comment.Oct 4 2011, 12:23 PM

I think I can remember what this bug was talking about, and I believe it is now fixed.

Meno25 added a comment.Oct 7 2011, 5:04 PM

(In reply to comment #6)

I'm not sure what the bug was, and so i am not sure what i should test.
I would guess that it's solved, because the RTL gadget mentioned in the
description was deleted and because 1.18 changed so many things in this regard.
Meno25, can you please verify this?

Verified fixed. (Running on 1.18wmf1 (r99094).) Thanks.