Page MenuHomePhabricator

Clicking the "remove" button in the link context menu for a newly-created link is a no-op
Closed, ResolvedPublic1 Estimated Story Points

Description

Clicking the "remove" button in the link context menu on a pre-existing link (internal/external/…) removes the link, as expected. Doing so on a newly-created link (in this edit session) doesn't do anything. Is the wrong bit of the linmod getting read or something odd?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 3 2017, 4:37 PM
DLynch added a subscriber: DLynch.Feb 14 2017, 6:00 PM

I can't reproduce this with newly-created links. More details?

Jdforrester-WMF closed this task as Resolved.Mar 24 2017, 10:18 PM
Jdforrester-WMF assigned this task to DLynch.

I think this is me finding T143261: Paste identical annotated content into (end of?) an annotation serialises very poorly because it gets double-annotated again and not realising it (re-creating links). Looks to be solved in that work.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 24 2017, 10:18 PM